Skip to content

← Actionable
Unratedamended

OpenClaw's Slack plugin approvals used the exec approver gate for plugin actions

CVE-2026-32906GHSA-wv26-j37q-2g7p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.5.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.5.12
    Fixed in
    2026.5.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2026-32906: 0.17% estimated exploitation activity in the next 30 days; percentile 6.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Slack plugin approvals used the exec approver gate for plugin actions. In affected versions, a Slack user authorized only for exec approvals could resolve a plugin approval through the exec approver gate. This advisory is scoped to the named feature and configuration. It does not change OpenClaw's trusted-operator model: authenticated Gateway operators, installed plugins, and intentional local execution surfaces remain trusted unless a separate policy, approval, allowlist, sandbox, or auth boundary is crossed. Impact When the affected feature is enabled and reachable, this could approve a plugin action outside the operator's intended approval split. Practical impact depends on the operator's configuration and whether lower-trust input can reach that path. Patched Versions The first stable patched version is 2026.5.12. Mitigations keep approval allowlists aligned and review Slack approval actions manually until patched. As general hardening, keep channel and tool allowlists…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wv26-j37q-2g7p

  2. Revision 1 · created ·

    Published from osv record GHSA-wv26-j37q-2g7p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32906

Advisory: OpenClaw's Slack plugin approvals used the exec approver gate for plugin actions
IDs: CVE-2026-32906, GHSA-wv26-j37q-2g7p
Record: https://patchnext.com/advisories/cve-2026-32906 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.5.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.5.12; fixed in 2026.5.12

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wv26-j37q-2g7p (OSV record GHSA-wv26-j37q-2g7p lists affected ranges: npm openclaw >=0 <2026.5.12 (fixed))
- Verified: https://github.com/advisories/GHSA-wv26-j37q-2g7p (GitHub-reviewed advisory GHSA-wv26-j37q-2g7p lists affected ranges: npm openclaw >=0 <2026.5.12)

Commands are suggestions: review each one before running it.

Loading voting…