Skip to content

← Actionable
High, CVSS 8.3amended

OpenClaw: Non-owner chat senders could issue device-pairing bootstrap codes

CVE-2026-32905GHSA-xr4f-mjxj-w6w5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.5.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.5.4
    Fixed in
    2026.5.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-32905: 0.24% estimated exploitation activity in the next 30 days; percentile 15.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The bundled device-pair plugin exposed /pair on normal chat command surfaces. In affected releases, authorized non-owner chat senders could issue device-pairing bootstrap codes without having owner, admin, or pairing scope. This issue does not affect unauthenticated users. The caller must already be allowed to send commands to the agent through a configured chat channel. Affected configurations This affects deployments where the bundled device-pair plugin is enabled and a non-owner sender is authorized to use normal chat commands, such as in a configured Telegram, Discord, or Slack agent. Impact A non-owner authorized sender could create a setup code and use it before expiry to enroll a device with operator/node capabilities. That device would then retain persistent credentials until removed. Patched Versions The first stable patched version is 2026.5.4. Mitigations Upgrade to openclaw@2026.5.4 or later. Review paired devices and remove any unexpected entries. In shared chat…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xr4f-mjxj-w6w5

  2. Revision 1 · created ·

    Published from osv record GHSA-xr4f-mjxj-w6w5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32905

Advisory: OpenClaw: Non-owner chat senders could issue device-pairing bootstrap codes
IDs: CVE-2026-32905, GHSA-xr4f-mjxj-w6w5
Record: https://patchnext.com/advisories/cve-2026-32905 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.5.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.5.4; fixed in 2026.5.4

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xr4f-mjxj-w6w5 (OSV record GHSA-xr4f-mjxj-w6w5 lists affected ranges: npm openclaw >=0 <2026.5.4 (fixed))
- Verified: https://github.com/advisories/GHSA-xr4f-mjxj-w6w5 (GitHub-reviewed advisory GHSA-xr4f-mjxj-w6w5 lists affected ranges: npm openclaw >=0 <2026.5.4)

Commands are suggestions: review each one before running it.

Loading voting…