Skip to content

← Actionable
Medium, CVSS 5.3amended

OpenClaw ACP client has permission auto-approval bypass via untrusted tool metadata

CVE-2026-32898GHSA-7jx5-9fjg-hp4m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.23), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    <= 2026.2.22-2
    Fixed in
    2026.2.23

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-32898: 0.26% estimated exploitation activity in the next 30 days; percentile 18.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability Summary The OpenClaw ACP client could auto-approve tool calls based on untrusted metadata and permissive name heuristics. A malicious or compromised ACP tool invocation could bypass expected interactive approval prompts for read-class operations. Affected Packages / Versions - Package: npm openclaw - Affected published versions: <= 2026.2.22-2 (latest published as of February 24, 2026 is 2026.2.22-2) - Patched in code on main: 2026.2.23 (released) Technical Details - Permission classification trusted incoming toolCall.kind and heuristic name matching. - Non-core read-like names and spoofed kind metadata could reach auto-approve paths. - read operations were not scoped strongly enough to cwd in all metadata/title forms. Fix - Require trusted core tool IDs for auto-approval and ignore untrusted toolCall.kind as an authorization source. - Scope read auto-approval to cwd-resolved paths. - Add stricter tool-name validation and regression coverage for spoofed kind and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7jx5-9fjg-hp4m

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-7jx5-9fjg-hp4m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32898

Advisory: OpenClaw ACP client has permission auto-approval bypass via untrusted tool metadata
IDs: CVE-2026-32898, GHSA-7jx5-9fjg-hp4m
Record: https://patchnext.com/advisories/cve-2026-32898 (revision 3, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.23. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected <= 2026.2.22-2; fixed in 2026.2.23

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7jx5-9fjg-hp4m (OSV record GHSA-7jx5-9fjg-hp4m lists affected ranges: npm openclaw >=0 <2026.2.23 (fixed))
- Verified: https://github.com/advisories/GHSA-7jx5-9fjg-hp4m (GitHub-reviewed advisory GHSA-7jx5-9fjg-hp4m lists affected ranges: npm openclaw >=0 <=2026.2.22-2)

Commands are suggestions: review each one before running it.

Loading voting…