Skip to content

← Actionable
Low, CVSS 2.1amended

OpenClaw reuses the gateway auth token in the owner ID prompt hashing fallback

CVE-2026-32897GHSA-v6x2-2qvm-6gv8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.22), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    <= 2026.2.21-2
    Fixed in
    2026.2.22

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-32897: 0.27% estimated exploitation activity in the next 30 days; percentile 18.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability OpenClaw reused gateway.auth.token (and gateway.remote.token) as a fallback hash secret for owner-ID prompt obfuscation when commands.ownerDisplay=hash and commands.ownerDisplaySecret was unset. This created secret dual-use between gateway authentication and prompt metadata hashing. Impact - Auth-secret dual-use across security domains (gateway auth and prompt metadata hashing). - Hash outputs are visible to third-party model providers in system prompts. - No direct plaintext token disclosure. - Practical risk is highest when operators use weak gateway tokens and leave owner hash secret unset. Affected Packages / Versions - Package: openclaw (npm) - Latest affected published version: 2026.2.21-2 - Vulnerable range: <= 2026.2.21-2 - Patched version (planned next release): 2026.2.22 Affected Components - src/agents/cli-runner/helpers.ts - src/agents/pi-embedded-runner/run/attempt.ts - src/agents/pi-embedded-runner/compact.ts Remediation - Added a shared owner-display…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-v6x2-2qvm-6gv8

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-v6x2-2qvm-6gv8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32897

Advisory: OpenClaw reuses the gateway auth token in the owner ID prompt hashing fallback
IDs: CVE-2026-32897, GHSA-v6x2-2qvm-6gv8
Record: https://patchnext.com/advisories/cve-2026-32897 (revision 3, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.22. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected <= 2026.2.21-2; fixed in 2026.2.22

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v6x2-2qvm-6gv8 (OSV record GHSA-v6x2-2qvm-6gv8 lists affected ranges: npm openclaw >=0 <2026.2.22 (fixed))
- Verified: https://github.com/advisories/GHSA-v6x2-2qvm-6gv8 (GitHub-reviewed advisory GHSA-v6x2-2qvm-6gv8 lists affected ranges: npm openclaw >=0 <=2026.2.21-2)

Commands are suggestions: review each one before running it.

Loading voting…