Parse Server vulnerable to schema poisoning via prototype pollution in deep copy
CVE-2026-32878GHSA-9ccr-fpp6-78qf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.6.0-alpha.20, 8.6.44), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- >= 9.0.0, < 9.6.0-alpha.20< 8.6.44
- Fixed in
- 8.6.44, 9.6.0-alpha.20
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9ccr-fpp6-78qf lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.44 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9ccr-fpp6-78qf lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.44
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-32878: 0.36% estimated exploitation activity in the next 30 days; percentile 29.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An attacker can bypass the default request keyword denylist protection and the class-level permission for adding fields by sending a crafted request that exploits prototype pollution in the deep copy mechanism. This allows injecting fields into class schemas that have field addition locked down, and can cause permanent schema type conflicts that cannot be resolved even with the master key. Patches The vulnerable third-party deep copy library has been replaced with a built-in deep clone mechanism that handles prototype properties safely, allowing the existing denylist check to correctly detect and reject the prohibited keyword. Workarounds None. Vulnerability Independence This vulnerability is not caused by or dependent on a vulnerability in a third-party dependency. The third-party deepcopy library that was replaced in the fix has no known CVE or security advisory regarding this. The library functions as designed. It is not vulnerable. The vulnerability is in parse-server's…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9ccr-fpp6-78qf
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-9ccr-fpp6-78qf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32878 Advisory: Parse Server vulnerable to schema poisoning via prototype pollution in deep copy IDs: CVE-2026-32878, GHSA-9ccr-fpp6-78qf Record: https://patchnext.com/advisories/cve-2026-32878 (revision 3, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 9.6.0-alpha.20, 8.6.44. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected >= 9.0.0, < 9.6.0-alpha.20; < 8.6.44; fixed in 8.6.44, 9.6.0-alpha.20 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9ccr-fpp6-78qf (OSV record GHSA-9ccr-fpp6-78qf lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.44 (fixed)) - Verified: https://github.com/advisories/GHSA-9ccr-fpp6-78qf (GitHub-reviewed advisory GHSA-9ccr-fpp6-78qf lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.44) Commands are suggestions: review each one before running it.
Loading voting…