Skip to content

← Actionable
High, CVSS 7.5amended

UltraJSON has a Memory Leak parsing large integers allows DoS

CVE-2026-32874GHSA-wgvc-ghv9-3pmm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ujson 5.12.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ujson

    Affected
    >= 5.4.0, <= 5.11.0
    Fixed in
    5.12.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-32874: 0.50% estimated exploitation activity in the next 30 days; percentile 42.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary ujson 5.4.0 to 5.11.0 inclusive contain an accumulating memory leak in JSON parsing large (outside of the range [-2^63, 2^64 - 1]) integers. Exploitability Any service that calls ujson.load()/ujson.loads()/ujson.decode() on untrusted inputs is affected and vulnerable to denial of service attacks. Details The leaked memory is a copy of the string form of the integer plus an additional NULL byte. The leak occurs irrespective of whether the integer parses successfully or is rejected due to having more than sys.getintmaxstrdigits() digits, meaning that any sized leak per malicious JSON can be achieved provided that there is no limit on the overall size of the payload. Fix The leak is fixed in ujson 5.12.0 (4baeb950df780092bd3c89fc702a868e99a3a1d2). There are no workarounds beyond upgrading to an unaffected version. Credits Discovered by Cameron Criswell/Skevros using Coverage-guided fuzzing (libFuzzer + AddressSanitizer)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wgvc-ghv9-3pmm

  2. Revision 1 · created ·

    Published from osv record GHSA-wgvc-ghv9-3pmm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32874

Advisory: UltraJSON has a Memory Leak parsing large integers allows DoS
IDs: CVE-2026-32874, GHSA-wgvc-ghv9-3pmm
Record: https://patchnext.com/advisories/cve-2026-32874 (revision 2, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ujson 5.12.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ujson: affected >= 5.4.0, <= 5.11.0; fixed in 5.12.0

## Suggested inspection (read-only)
- `python -m pip show ujson`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ujson.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wgvc-ghv9-3pmm (OSV record GHSA-wgvc-ghv9-3pmm lists affected ranges: PyPI ujson >=5.4.0 <5.12.0 (fixed))
- Verified: https://github.com/advisories/GHSA-wgvc-ghv9-3pmm (GitHub-reviewed advisory GHSA-wgvc-ghv9-3pmm lists affected ranges: PyPI ujson >=5.4.0 <=5.11.0)

Commands are suggestions: review each one before running it.

Loading voting…