Skip to content

← Actionable
Medium, CVSS 6.9

Kirby has XML injection in its XML creator toolkit

CVE-2026-32870GHSA-9wfj-c55w-j9qr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 5.4.0, 4.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist getkirby/cms

    Affected
    < 4.9.0>= 5.0.0, < 5.4.0
    Fixed in
    4.9.0, 5.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:H/SA:N · score source
EPSS
  • CVE-2026-32870: 0.35% estimated exploitation activity in the next 30 days; percentile 28.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

TL;DR This vulnerability only affects Kirby sites that use the Xml data handler (e.g. Data::encode($string, 'xml')) or the Xml::create(), Xml::tag() or Xml::value() method(s) in site or plugin code. The Kirby core does not use any of the affected methods. If consumers use an affected method and cannot rule out input to these methods controlled by an attacker, Kirby strongly recommends that they update to a patch release. ---- Introduction XML strings contain structured data in tags and attributes. Depending on the used XML schema, this data can carry specific meaning that can lead to actions in other systems that parse and act on the XML data. Tags and attributes are detected based on their specific syntax, which includes characters such as <, , ", and &. If these characters are to be used verbatim in text within the XML string, they can be escaped using a <![CDATA[ ]] block. XML injection is an attack on a system generating or parsing XML files. By injecting special characters into…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9wfj-c55w-j9qr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32870

Advisory: Kirby has XML injection in its XML creator toolkit
IDs: CVE-2026-32870, GHSA-9wfj-c55w-j9qr
Record: https://patchnext.com/advisories/cve-2026-32870 (revision 1, source checked 26 Oct 2026, 14:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 5.4.0, 4.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getkirby/cms: affected < 4.9.0; >= 5.0.0, < 5.4.0; fixed in 4.9.0, 5.4.0

## Suggested inspection (read-only)
- Packagist getkirby/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getkirby/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9wfj-c55w-j9qr (GitHub-reviewed advisory GHSA-9wfj-c55w-j9qr lists affected ranges: Packagist getkirby/cms >=0 =5.0.0 <5.4.0)

Commands are suggestions: review each one before running it.

Loading voting…