Skip to content

← Actionable
High, CVSS 8.2

lz4_flex's decompression can leak information from uninitialized memory or reused output buffer

CVE-2026-32829GHSA-vvp9-7p8x-rfvv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lz4_flex 0.12.1, 0.11.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io lz4_flex

    Affected
    < 0.11.6>= 0.12.0, < 0.12.1
    Fixed in
    0.12.1, 0.11.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-32829: 0.62% estimated exploitation activity in the next 30 days; percentile 49.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Decompressing invalid LZ4 data can leak data from uninitialized memory, or can leak content from previous decompression operations when reusing an output buffer. Details The LZ4 block format defines a "match copy operation" which duplicates previously written data or data from the user-supplied dict. The position of that data is defined by an offset. The data is copied within the output buffer from the offset to the current output position. However, lz4flex did not properly detect invalid and out-of-bounds offset values properly, causing it to copy uninitialized data from the output buffer. Only the block based API functions are affected: lz4flex::block::{decompressinto, decompressintowithdict} When safe-decode is disabled additionally these functions are affected lz4flex::block::{decompress, decompresswithdict, decompresssizeprepended, decompresssizeprependedwithdict} All frame APIs are not affected. There are two affected use cases: - decompressing LZ4 data with the unsafe…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vvp9-7p8x-rfvv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32829

Advisory: lz4_flex's decompression can leak information from uninitialized memory or reused output buffer
IDs: CVE-2026-32829, GHSA-vvp9-7p8x-rfvv
Record: https://patchnext.com/advisories/cve-2026-32829 (revision 1, source checked 26 Oct 2026, 15:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lz4_flex 0.12.1, 0.11.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io lz4_flex: affected < 0.11.6; >= 0.12.0, < 0.12.1; fixed in 0.12.1, 0.11.6

## Suggested inspection (read-only)
- crates.io lz4_flex: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lz4_flex.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vvp9-7p8x-rfvv (GitHub-reviewed advisory GHSA-vvp9-7p8x-rfvv lists affected ranges: crates.io lz4_flex >=0 =0.12.0 <0.12.1)

Commands are suggestions: review each one before running it.

Loading voting…