Admidio is Missing Authorization on Forum Topic and Post Deletion
CVE-2026-32818GHSA-g375-5wmp-xr78
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (admidio/admidio 5.0.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist admidio/admidio
- Affected
- >= 5.0.0, <= 5.0.6
- Fixed in
- 5.0.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g375-5wmp-xr78 lists affected ranges: Packagist admidio/admidio >=5.0.0 <=5.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-32818: 0.24% estimated exploitation activity in the next 30 days; percentile 14.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The forum module in Admidio does not verify whether the current user has permission to delete forum topics or posts. Both the topicdelete and postdelete actions in forum.php only validate the CSRF token but perform no authorization check before calling delete(). Any authenticated user with forum access can delete any topic (with all its posts) or any individual post by providing its UUID. This is inconsistent with the save/edit operations, which properly check isAdministratorForum() and ownership before allowing modifications. Details Vulnerable Code Path 1: Topic Deletion File: D:\bugcrowd\admidio\repo\modules\forum.php, lines 98-108 The topicdelete handler validates CSRF but never calls $topic-isEditable(): The Topic class has an isEditable() method (lines 144-164 of ListConfiguration.php) that properly checks isAdministratorForum() and getAllEditableCategories('FOT'), but it is never called in the delete path. Vulnerable Code Path 2: Post Deletion File:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g375-5wmp-xr78
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32818 Advisory: Admidio is Missing Authorization on Forum Topic and Post Deletion IDs: CVE-2026-32818, GHSA-g375-5wmp-xr78 Record: https://patchnext.com/advisories/cve-2026-32818 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: admidio/admidio 5.0.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist admidio/admidio: affected >= 5.0.0, <= 5.0.6; fixed in 5.0.7 ## Suggested inspection (read-only) - Packagist admidio/admidio: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on admidio/admidio. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g375-5wmp-xr78 (GitHub-reviewed advisory GHSA-g375-5wmp-xr78 lists affected ranges: Packagist admidio/admidio >=5.0.0 <=5.0.6) Commands are suggestions: review each one before running it.
Loading voting…