Skip to content

← Actionable
Medium, CVSS 5.7

Admidio is Missing CSRF Validation on Role Delete, Activate, and Deactivate Actions

CVE-2026-32816GHSA-wwg8-6ffr-h4q2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (admidio/admidio 5.0.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-32816: 0.14% estimated exploitation activity in the next 30 days; percentile 3.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The delete, activate, and deactivate modes in modules/groups-roles/groupsroles.php perform destructive state changes on organizational roles but never validate an anti-CSRF token. The client-side UI passes a CSRF token to callUrlHideElement(), which includes it in the POST body, but the server-side handlers ignore $POST["admcsrftoken"] entirely for these three modes. An attacker who can discover a role UUID (visible in the public cards view when the module is publicly accessible) can embed a forged POST form on any external page and trick any user with the rolassignroles right into deleting or toggling roles for the organization. Role deletion is permanent and cascades to all memberships, event associations, and rights data. Details CSRF Token Is Sent but Never Validated File: D:/bugcrowd/admidio/repo/modules/groups-roles/groupsroles.php, lines 150-173 The save mode (lines 143-148) is CSRF-protected via RolesService::save() which calls…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wwg8-6ffr-h4q2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32816

Advisory: Admidio is Missing CSRF Validation on Role Delete, Activate, and Deactivate Actions
IDs: CVE-2026-32816, GHSA-wwg8-6ffr-h4q2
Record: https://patchnext.com/advisories/cve-2026-32816 (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: admidio/admidio 5.0.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist admidio/admidio: affected >= 5.0.0, <= 5.0.6; fixed in 5.0.7

## Suggested inspection (read-only)
- Packagist admidio/admidio: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on admidio/admidio.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wwg8-6ffr-h4q2 (GitHub-reviewed advisory GHSA-wwg8-6ffr-h4q2 lists affected ranges: Packagist admidio/admidio >=5.0.0 <=5.0.6)

Commands are suggestions: review each one before running it.

Loading voting…