Apache Spark History Server allows stored cross-site scripting through unescaped application names
CVE-2026-32773GHSA-9437-39hj-3c93
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.spark:spark-core_2.12 3.5.8; org.apache.spark:spark-core_2.13 3.5.8; pyspark 3.5.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.spark:spark-core_2.12
- Affected
- >= 3.0.0, < 3.5.8
- Fixed in
- 3.5.8
Maven org.apache.spark:spark-core_2.13
- Affected
- >= 3.0.0, < 3.5.8
- Fixed in
- 3.5.8
PyPI pyspark
- Affected
- >= 3.0.0, < 3.5.8
- Fixed in
- 3.5.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9437-39hj-3c93 lists affected ranges: PyPI pyspark >=3.0.0 =3.0.0 =3.0.0 <3.5.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9437-39hj-3c93 lists affected ranges: PyPI pyspark >=3.0.0 =3.0.0 =3.0.0 <3.5.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-32773: 0.41% estimated exploitation activity in the next 30 days; percentile 35.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later. This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page. Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9437-39hj-3c93
- Revision 1 · created ·
Published from osv record GHSA-9437-39hj-3c93
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32773 Advisory: Apache Spark History Server allows stored cross-site scripting through unescaped application names IDs: CVE-2026-32773, GHSA-9437-39hj-3c93 Record: https://patchnext.com/advisories/cve-2026-32773 (revision 2, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.spark:spark-core_2.12 3.5.8; org.apache.spark:spark-core_2.13 3.5.8; pyspark 3.5.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.spark:spark-core_2.12: affected >= 3.0.0, < 3.5.8; fixed in 3.5.8 - Maven org.apache.spark:spark-core_2.13: affected >= 3.0.0, < 3.5.8; fixed in 3.5.8 - PyPI pyspark: affected >= 3.0.0, < 3.5.8; fixed in 3.5.8 ## Suggested inspection (read-only) - Maven org.apache.spark:spark-core_2.12: check the installed version with your package manager. - Maven org.apache.spark:spark-core_2.13: check the installed version with your package manager. - `python -m pip show pyspark`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.spark:spark-core_2.12, org.apache.spark:spark-core_2.13, pyspark. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9437-39hj-3c93 (OSV record GHSA-9437-39hj-3c93 lists affected ranges: PyPI pyspark >=3.0.0 =3.0.0 =3.0.0 <3.5.8 (fixed)) - Verified: https://github.com/advisories/GHSA-9437-39hj-3c93 (GitHub-reviewed advisory GHSA-9437-39hj-3c93 lists affected ranges: PyPI pyspark >=3.0.0 =3.0.0 =3.0.0 <3.5.8) Commands are suggestions: review each one before running it.
Loading voting…