Parse Server LiveQuery subscription with invalid regular expression crashes server
CVE-2026-32770GHSA-827p-g5x5-h86c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.6.0-alpha.19, 8.6.43), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- >= 9.0.0, < 9.6.0-alpha.19< 8.6.43
- Fixed in
- 8.6.43, 9.6.0-alpha.19
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-827p-g5x5-h86c lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.43 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-827p-g5x5-h86c lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.43
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-32770: 0.57% estimated exploitation activity in the next 30 days; percentile 47.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A remote attacker can crash the Parse Server by subscribing to a LiveQuery with an invalid regular expression pattern. The server process terminates when the invalid pattern reaches the regex engine during subscription matching, causing denial of service for all connected clients. Patches The fix validates regular expression patterns at subscription time, rejecting invalid patterns before they are stored. Additionally, a defense-in-depth try-catch prevents any subscription matching error from crashing the server process. Workarounds Disable LiveQuery if it is not needed.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-827p-g5x5-h86c
- Revision 1 · created ·
Published from osv record GHSA-827p-g5x5-h86c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32770 Advisory: Parse Server LiveQuery subscription with invalid regular expression crashes server IDs: CVE-2026-32770, GHSA-827p-g5x5-h86c Record: https://patchnext.com/advisories/cve-2026-32770 (revision 2, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 9.6.0-alpha.19, 8.6.43. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected >= 9.0.0, < 9.6.0-alpha.19; < 8.6.43; fixed in 8.6.43, 9.6.0-alpha.19 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-827p-g5x5-h86c (OSV record GHSA-827p-g5x5-h86c lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.43 (fixed)) - Verified: https://github.com/advisories/GHSA-827p-g5x5-h86c (GitHub-reviewed advisory GHSA-827p-g5x5-h86c lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.43) Commands are suggestions: review each one before running it.
Loading voting…