Skip to content

← Actionable
Medium, CVSS 6.3

astral-tokio-tar insufficiently validates PAX extensions during extraction

CVE-2026-32766GHSA-6gx3-4362-rf54

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (astral-tokio-tar 0.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-32766: 0.25% estimated exploitation activity in the next 30 days; percentile 16.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In versions 0.5.6 and earlier of astral-tokio-tar, malformed PAX extensions were silently skipped when parsing tar archives. This silent skipping (rather than rejection) of invalid PAX extensions could be used as a building block for a parser differential, for example by having astral-tokio-tar silently skip a malformed GNU “long link” extension so that a subsequent parser would misinterpret the extension. In practice, exploiting this behavior in astral-tokio-tar requires a secondary misbehaving tar parser, i.e. one that insufficiently validates malformed PAX extensions and interprets them rather than skipping or erroring on them. Consequently this advisory is considered low-severity within astral-tokio-tar itself, as it requires a separate vulnerability against any unrelated tar parser. Patches Versions 0.6.0 and newer of astral-tokio-tar reject invalid PAX extensions, rather than silently skipping them. Workarounds Users are advised to upgrade to version 0.6.0 or newer to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6gx3-4362-rf54

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32766

Advisory: astral-tokio-tar insufficiently validates PAX extensions during extraction
IDs: CVE-2026-32766, GHSA-6gx3-4362-rf54
Record: https://patchnext.com/advisories/cve-2026-32766 (revision 1, source checked 26 Oct 2026, 15:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: astral-tokio-tar 0.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io astral-tokio-tar: affected <= 0.5.6; fixed in 0.6.0

## Suggested inspection (read-only)
- crates.io astral-tokio-tar: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on astral-tokio-tar.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6gx3-4362-rf54 (GitHub-reviewed advisory GHSA-6gx3-4362-rf54 lists affected ranges: crates.io astral-tokio-tar >=0 <=0.5.6)

Commands are suggestions: review each one before running it.

Loading voting…