Skip to content

← Actionable
Medium, CVSS 4.3amended

Parse Server session creation endpoint allows overwriting server-generated session fields

CVE-2026-32742GHSA-5v7g-9h8f-8pgg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.6.0-alpha.17, 8.6.42), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    >= 9.0.0, < 9.6.0-alpha.17< 8.6.42
    Fixed in
    9.6.0-alpha.17, 8.6.42

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-32742: 0.32% estimated exploitation activity in the next 30 days; percentile 24.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authenticated user can overwrite server-generated session fields (sessionToken, expiresAt, createdWith) when creating a session object via POST /classes/Session. This allows bypassing the server's session expiration policy by setting an arbitrary far-future expiration date. It also allows setting a predictable session token value. Patches The session creation endpoint now filters out server-generated fields from user-supplied data, preventing them from being overwritten. Workarounds Add a beforeSave trigger on the Session class to validate and reject or strip any user-supplied values for sessionToken, expiresAt, and createdWith.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5v7g-9h8f-8pgg

  2. Revision 1 · created ·

    Published from osv record GHSA-5v7g-9h8f-8pgg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32742

Advisory: Parse Server session creation endpoint allows overwriting server-generated session fields
IDs: CVE-2026-32742, GHSA-5v7g-9h8f-8pgg
Record: https://patchnext.com/advisories/cve-2026-32742 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 9.6.0-alpha.17, 8.6.42. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected >= 9.0.0, < 9.6.0-alpha.17; < 8.6.42; fixed in 9.6.0-alpha.17, 8.6.42

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5v7g-9h8f-8pgg (OSV record GHSA-5v7g-9h8f-8pgg lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.42 (fixed))
- Verified: https://github.com/advisories/GHSA-5v7g-9h8f-8pgg (GitHub-reviewed advisory GHSA-5v7g-9h8f-8pgg lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.42)

Commands are suggestions: review each one before running it.

Loading voting…