ApostropheCMS has Arbitrary File Write (Zip Slip / Path Traversal) in Import-Export Gzip Extraction
CVE-2026-32731GHSA-mwxc-m426-3f78
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@apostrophecms/import-export 3.5.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @apostrophecms/import-export
- Affected
- <= 3.5.2
- Fixed in
- 3.5.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mwxc-m426-3f78 lists affected ranges: npm @apostrophecms/import-export >=0 <=3.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mwxc-m426-3f78 lists affected ranges: npm @apostrophecms/import-export >=0 <3.5.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-32731: 0.54% estimated exploitation activity in the next 30 days; percentile 45.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Reported: 2026-03-08 Status: patched and released in version 3.5.3 of @apostrophecms/import-export --- Product | Field | Value | |---|---| | Repository | apostrophecms/apostrophe (monorepo) | | Affected Package | @apostrophecms/import-export | | Affected File | packages/import-export/lib/formats/gzip.js | | Affected Function | extract(filepath, exportPath) — lines ~132–157 | | Minimum Required Permission | Global Content Modify (any editor-level user with import access) | --- Vulnerability Summary The extract() function in gzip.js constructs file-write paths using: path.join() does not resolve or sanitise traversal segments such as ../. It concatenates them as-is, meaning a tar entry named ../../evil.js resolves to a path outside the intended extraction directory. No canonical-path check is performed before the write stream is opened. This is a textbook Zip Slip vulnerability. Any user who has been granted the Global Content Modify permission — a role routinely assigned to content…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mwxc-m426-3f78
- Revision 2 · amended ·
Amended from osv record GHSA-mwxc-m426-3f78
- Revision 1 · created ·
Published from ghsa record GHSA-mwxc-m426-3f78
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32731 Advisory: ApostropheCMS has Arbitrary File Write (Zip Slip / Path Traversal) in Import-Export Gzip Extraction IDs: CVE-2026-32731, GHSA-mwxc-m426-3f78 Record: https://patchnext.com/advisories/cve-2026-32731 (revision 3, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @apostrophecms/import-export 3.5.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @apostrophecms/import-export: affected <= 3.5.2; fixed in 3.5.3 ## Suggested inspection (read-only) - `npm ls @apostrophecms/import-export --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @apostrophecms/import-export. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mwxc-m426-3f78 (GitHub-reviewed advisory GHSA-mwxc-m426-3f78 lists affected ranges: npm @apostrophecms/import-export >=0 <=3.5.2) - Verified: https://osv.dev/vulnerability/GHSA-mwxc-m426-3f78 (OSV record GHSA-mwxc-m426-3f78 lists affected ranges: npm @apostrophecms/import-export >=0 <3.5.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…