Skip to content

← Actionable
Low, CVSS 3.6amended

Stored XSS in Memray-generated HTML reports via unescaped command-line metadata

CVE-2026-32722GHSA-r5pr-887v-m2w9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (memray 1.19.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI memray

    Affected
    < 1.19.2
    Fixed in
    1.19.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.6 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
EPSS
  • CVE-2026-32722: 0.31% estimated exploitation activity in the next 30 days; percentile 24.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Prior to Memray 1.19.2, Memray rendered the command line of the tracked process directly into generated HTML reports without escaping. Because there was no escaping, attacker-controlled command line arguments were inserted as raw HTML into the generated report. This allowed JavaScript execution when a victim opened the generated report in a browser. Affected Version - Memray version: 1.19.1 and earlier Remediation Upgrade to Memray 1.19.2, and avoid attaching Memray to untrusted processes until you have upgraded. Root Cause Jinja is used to embed the process's command line arguments into the generated flame graph or table report. Memray has not been telling Jinja to HTML escape the command line arguments when writing them into the HTML, leading to a stored XSS vulnerability. Impact An attacker who can influence the script name or command-line arguments of a profiled program can inject HTML/JavaScript into Memray-generated HTML reports (both memray flamegraph and memray table…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-r5pr-887v-m2w9

  2. Revision 1 · created ·

    Published from osv record GHSA-r5pr-887v-m2w9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32722

Advisory: Stored XSS in Memray-generated HTML reports via unescaped command-line metadata
IDs: CVE-2026-32722, GHSA-r5pr-887v-m2w9
Record: https://patchnext.com/advisories/cve-2026-32722 (revision 2, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: memray 1.19.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI memray: affected < 1.19.2; fixed in 1.19.2

## Suggested inspection (read-only)
- `python -m pip show memray`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on memray.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r5pr-887v-m2w9 (OSV record GHSA-r5pr-887v-m2w9 lists affected ranges: PyPI memray >=0 <1.19.2 (fixed))
- Verified: https://github.com/advisories/GHSA-r5pr-887v-m2w9 (GitHub-reviewed advisory GHSA-r5pr-887v-m2w9 lists affected ranges: PyPI memray >=0 <1.19.2)

Commands are suggestions: review each one before running it.

Loading voting…