SciTokens has an Authorization Bypass via Incorrect Scope Path Prefix Checking
CVE-2026-32716GHSA-w8fp-g9rh-34jh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (scitokens 1.9.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI scitokens
- Affected
- < 1.9.6
- Fixed in
- 1.9.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w8fp-g9rh-34jh lists affected ranges: PyPI scitokens >=0 <1.9.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w8fp-g9rh-34jh lists affected ranges: PyPI scitokens >=0 <1.9.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-32716: 0.40% estimated exploitation activity in the next 30 days; percentile 33.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The Enforcer incorrectly validates scope paths by using a simple prefix match (startswith). This allows a token with access to a specific path (e.g., /john) to also access sibling paths that start with the same prefix (e.g., /johnathan, /johnny), which is an Authorization Bypass. Details File: src/scitokens/scitokens.py Methods: validatescp and validatescope Vulnerable Code Snippets: In validatescp (around line 696): In validatescope (around line 722): If normpath (authorized) is /john and normrequestedpath (requested) is /johnathan, startswith returns True, incorrectly granting access. PoC Impact This bug allows a user to access resources they are not authorized for. For example, if a system uses usernames as top-level directories in a shared storage, a user john might be able to read or write to the directory of user johnathan simply because their names share a prefix.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-w8fp-g9rh-34jh
- Revision 1 · created ·
Published from osv record GHSA-w8fp-g9rh-34jh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32716 Advisory: SciTokens has an Authorization Bypass via Incorrect Scope Path Prefix Checking IDs: CVE-2026-32716, GHSA-w8fp-g9rh-34jh Record: https://patchnext.com/advisories/cve-2026-32716 (revision 2, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: scitokens 1.9.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI scitokens: affected < 1.9.6; fixed in 1.9.6 ## Suggested inspection (read-only) - `python -m pip show scitokens`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on scitokens. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w8fp-g9rh-34jh (OSV record GHSA-w8fp-g9rh-34jh lists affected ranges: PyPI scitokens >=0 <1.9.6 (fixed)) - Verified: https://github.com/advisories/GHSA-w8fp-g9rh-34jh (GitHub-reviewed advisory GHSA-w8fp-g9rh-34jh lists affected ranges: PyPI scitokens >=0 <1.9.6) Commands are suggestions: review each one before running it.
Loading voting…