Skip to content

← Actionable
Critical, CVSS 9.8amended

SciTokens is vulnerable to SQL Injection in KeyCache

CVE-2026-32714GHSA-rh5m-2482-966c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (scitokens 1.9.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-32714: 0.50% estimated exploitation activity in the next 30 days; percentile 42.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The KeyCache class in scitokens was vulnerable to SQL Injection because it used Python's str.format() to construct SQL queries with user-supplied data (such as issuer and keyid). This allowed an attacker to execute arbitrary SQL commands against the local SQLite database. Ran the POC below locally. Details File: src/scitokens/utils/keycache.py Vulnerable Code Snippets 1. In addkeyinfo (around line 74): 2. In addkeyinfo (around lines 89 and 94): 3. In deletecacheentry (around line 128): 4. In addnegativecacheentry (around lines 148 and 152): 5. In getkeyinfo (around lines 193 and 198): PoC Impact An attacker who can influence the issuer or keyid (e.g., through a malicious token or issuer endpoint) could: 1. Modify or Delete Cache Entries: Clear the entire key cache or inject malicious keys. 2. Information Leakage: Query other tables or system information if SQLite is configured with certain extensions. 3. Potential RCE: In some configurations, SQLite can be used to achieve…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-rh5m-2482-966c

  2. Revision 2 · amended ·

    Amended from osv record GHSA-rh5m-2482-966c

  3. Revision 1 · created ·

    Published from ghsa record GHSA-rh5m-2482-966c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32714

Advisory: SciTokens is vulnerable to SQL Injection in KeyCache
IDs: CVE-2026-32714, GHSA-rh5m-2482-966c
Record: https://patchnext.com/advisories/cve-2026-32714 (revision 3, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: scitokens 1.9.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI scitokens: affected < 1.9.6; fixed in 1.9.6

## Suggested inspection (read-only)
- `python -m pip show scitokens`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on scitokens.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rh5m-2482-966c (GitHub-reviewed advisory GHSA-rh5m-2482-966c lists affected ranges: PyPI scitokens >=0 <1.9.6)
- Verified: https://osv.dev/vulnerability/GHSA-rh5m-2482-966c (OSV record GHSA-rh5m-2482-966c lists affected ranges: PyPI scitokens >=0 <1.9.6 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…