Skip to content

← Actionable
High, CVSS 7.8amended

pydicom has a path traversal in FileSet/DICOMDIR ReferencedFileID allows file access outside the File-set root

CVE-2026-32711GHSA-v856-2rf8-9f28

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pydicom 3.0.2, 2.4.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pydicom

    Affected
    >= 3.0.0, <= 3.0.1< 2.4.5
    Fixed in
    2.4.5, 3.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-32711: 0.29% estimated exploitation activity in the next 30 days; percentile 21.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A crafted DICOMDIR can set ReferencedFileID to a path outside the File-set root. pydicom resolves the path only to confirm that it exists, but does not verify that the resolved path remains under the File-set root. Subsequent public FileSet operations such as copy(), write(), and remove()+write(useexisting=True) use that unchecked path in file I/O operations. This allows arbitrary file read/copy and, in some flows, move/delete outside the File-set root. Details Verified on pydicom 3.1.0.dev0. Relevant logic is in src/pydicom/fileset.py: - RecordNode.fileid converts ReferencedFileID directly to Path(...) - FileSet.load() checks only (root / fileid).resolve(strict=True) to confirm existence - FileSet.load() does not verify that the final resolved path is contained within the File-set root - FileInstance.path returns self.fileset.path / self.node.fileid - FileSet.copy() uses shutil.copyfile(instance.path, dst) - FileSet.write() uses Path(instance.path).unlink() and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v856-2rf8-9f28

  2. Revision 1 · created ·

    Published from osv record GHSA-v856-2rf8-9f28

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32711

Advisory: pydicom has a path traversal in FileSet/DICOMDIR ReferencedFileID allows file access outside the File-set root
IDs: CVE-2026-32711, GHSA-v856-2rf8-9f28
Record: https://patchnext.com/advisories/cve-2026-32711 (revision 2, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pydicom 3.0.2, 2.4.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pydicom: affected >= 3.0.0, <= 3.0.1; < 2.4.5; fixed in 2.4.5, 3.0.2

## Suggested inspection (read-only)
- `python -m pip show pydicom`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pydicom.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v856-2rf8-9f28 (OSV record GHSA-v856-2rf8-9f28 lists affected ranges: PyPI pydicom >=3.0.0 =0 <2.4.5 (fixed))
- Verified: https://github.com/advisories/GHSA-v856-2rf8-9f28 (GitHub-reviewed advisory GHSA-v856-2rf8-9f28 lists affected ranges: PyPI pydicom >=3.0.0 =0 <2.4.5)

Commands are suggestions: review each one before running it.

Loading voting…