Devise has a confirmable "change email" race condition permits user to confirm email they have no access to
CVE-2026-32700GHSA-57hq-95w6-v4fc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (devise 5.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems devise
- Affected
- <= 5.0.2
- Fixed in
- 5.0.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-57hq-95w6-v4fc lists affected ranges: RubyGems devise >=0 <=5.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.0 · CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-32700: 0.29% estimated exploitation activity in the next 30 days; percentile 21.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A race condition in Devise's Confirmable module allows an attacker to confirm an email address they do not own. This affects any Devise application using the reconfirmable option (the default when using Confirmable with email changes). By sending two concurrent email change requests, an attacker can desynchronize the confirmationtoken and unconfirmedemail fields. The confirmation token is sent to an email the attacker controls, but the unconfirmedemail in the database points to a victim's email address. When the attacker uses the token, the victim's email is confirmed on the attacker's account. Patches This is patched in Devise v5.0.3. Users should upgrade as soon as possible. Workarounds Applications can override this specific method from Devise models to force unconfirmedemail to be persisted when unchanged: (assuming your model is User) Note: Mongoid does not seem to respect that willchange! should force the attribute to be persisted, even if it did not really change, so…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-57hq-95w6-v4fc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32700 Advisory: Devise has a confirmable "change email" race condition permits user to confirm email they have no access to IDs: CVE-2026-32700, GHSA-57hq-95w6-v4fc Record: https://patchnext.com/advisories/cve-2026-32700 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: devise 5.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems devise: affected <= 5.0.2; fixed in 5.0.3 ## Suggested inspection (read-only) - RubyGems devise: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on devise. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-57hq-95w6-v4fc (GitHub-reviewed advisory GHSA-57hq-95w6-v4fc lists affected ranges: RubyGems devise >=0 <=5.0.2) Commands are suggestions: review each one before running it.
Loading voting…