Skip to content

← Actionable
High, CVSS 8.7amended

SimpleEval: Objects (including modules) can leak dangerous modules through to direct access inside the sandbox

CVE-2026-32640GHSA-44vg-5wv2-h2hg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (simpleeval 1.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-32640: 0.54% estimated exploitation activity in the next 30 days; percentile 45.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact If the objects passed in as names to SimpleEval have modules or other disallowed / dangerous objects available as attrs. Additionally, dangerous functions or modules could be accessed by passing them as callbacks to other safe functions to call. Examples (found by @ByamB4): Any module where non-underscore attribute chains reach os or sys: - os.path, pathlib, shutil, glob (direct .os / .sys attributes) - statistics (has .sys) - numpy (has .ctypeslib.os and .f2py.sys) - urllib.parse (has .warnings.sys) Patches The latest version 1.0.5 has this issue fixed. Workarounds Don't pass in objects or modules which have direct attributes to potentially dangerous items. Use a wrapper to wrap the potentially vulnerable items (See the ModuleWrapper in version 1.0.5)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-44vg-5wv2-h2hg

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-44vg-5wv2-h2hg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32640

Advisory: SimpleEval: Objects (including modules) can leak dangerous modules through to direct access inside the sandbox
IDs: CVE-2026-32640, GHSA-44vg-5wv2-h2hg
Record: https://patchnext.com/advisories/cve-2026-32640 (revision 3, source checked 26 Oct 2026, 13:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: simpleeval 1.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI simpleeval: affected < 1.0.5; fixed in 1.0.5

## Suggested inspection (read-only)
- `python -m pip show simpleeval`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on simpleeval.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-44vg-5wv2-h2hg (OSV record GHSA-44vg-5wv2-h2hg lists affected ranges: PyPI simpleeval >=0 <1.0.5 (fixed))
- Verified: https://github.com/advisories/GHSA-44vg-5wv2-h2hg (GitHub-reviewed advisory GHSA-44vg-5wv2-h2hg lists affected ranges: PyPI simpleeval >=0 <1.0.5)

Commands are suggestions: review each one before running it.

Loading voting…