Angular vulnerable to XSS in i18n attribute bindings
CVE-2026-32635GHSA-g93w-mfhg-p222
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 22.0.0-next.0, < 22.0.0-next.3>= 21.0.0-next.0, < 21.2.4>= 20.0.0-next.0.0.0, < 20.3.18>= 19.0.0-next.0, < 19.2.20>= 17.0.0-next.0, <= 18.2.14
- Fixed in
- 22.0.0-next.3, 20.3.18, 19.2.20, 21.2.4
npm @angular/core
- Affected
- >= 22.0.0-next.0, < 22.0.0-next.3>= 21.0.0-next.0, < 21.2.4>= 20.0.0-next.0.0.0, < 20.3.18>= 19.0.0-next.0, < 19.2.20>= 17.0.0-next.0, <= 18.2.14
- Fixed in
- 22.0.0-next.3, 20.3.18, 19.2.20, 21.2.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g93w-mfhg-p222 lists affected ranges: npm @angular/core >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0.0.0 =19.0.0-next.0 =17.0.0-next.0 =22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0.0.0 =19.0.0-next.0 =17.0.0-next.0 <=18.2.14
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g93w-mfhg-p222 lists affected ranges: npm @angular/core >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0.0.0 =19.0.0-next.0 =17.0.0-next.0 =22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0.0.0 =19.0.0-next.0 =17.0.0-next.0 <=18.2.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-32635: 0.47% estimated exploitation activity in the next 30 days; percentile 40.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Cross-Site Scripting (XSS) vulnerability has been identified in the Angular runtime and compiler. It occurs when the application uses a security-sensitive attribute (for example href on an anchor tag) together with Angular's ability to internationalize attributes. Enabling internationalization for the sensitive attribute by adding i18n-<attribute name bypasses Angular's built-in sanitization mechanism, which when combined with a data binding to untrusted user-generated data can allow an attacker to inject a malicious script. The following example illustrates the issue: The following attributes have been confirmed to be vulnerable: - action - background - cite - codebase - data - formaction - href - itemtype - longdesc - poster - src - xlink:href Impact When exploited, this vulnerability allows an attacker to execute arbitrary code within the context of the vulnerable application's domain. This enables: - Session Hijacking: Stealing session cookies and authentication tokens. - Data…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-g93w-mfhg-p222
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-g93w-mfhg-p222
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32635 Advisory: Angular vulnerable to XSS in i18n attribute bindings IDs: CVE-2026-32635, GHSA-g93w-mfhg-p222 Record: https://patchnext.com/advisories/cve-2026-32635 (revision 3, source checked 26 Oct 2026, 12:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @angular/compiler 22.0.0-next.3, 21.2.4, 20.3.18, 19.2.20; @angular/core 22.0.0-next.3, 21.2.4, 20.3.18, 19.2.20. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @angular/compiler: affected >= 22.0.0-next.0, < 22.0.0-next.3; >= 21.0.0-next.0, < 21.2.4; >= 20.0.0-next.0.0.0, < 20.3.18; >= 19.0.0-next.0, < 19.2.20; >= 17.0.0-next.0, <= 18.2.14; fixed in 22.0.0-next.3, 20.3.18, 19.2.20, 21.2.4 - npm @angular/core: affected >= 22.0.0-next.0, < 22.0.0-next.3; >= 21.0.0-next.0, < 21.2.4; >= 20.0.0-next.0.0.0, < 20.3.18; >= 19.0.0-next.0, < 19.2.20; >= 17.0.0-next.0, <= 18.2.14; fixed in 22.0.0-next.3, 20.3.18, 19.2.20, 21.2.4 ## Suggested inspection (read-only) - `npm ls @angular/compiler --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @angular/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @angular/compiler, @angular/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g93w-mfhg-p222 (OSV record GHSA-g93w-mfhg-p222 lists affected ranges: npm @angular/core >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0.0.0 =19.0.0-next.0 =17.0.0-next.0 =22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0.0.0 =19.0.0-next.0 =17.0.0-next.0 <=18.2.14) - Verified: https://github.com/advisories/GHSA-g93w-mfhg-p222 (GitHub-reviewed advisory GHSA-g93w-mfhg-p222 lists affected ranges: npm @angular/core >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0.0.0 =19.0.0-next.0 =17.0.0-next.0 =22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0.0.0 =19.0.0-next.0 =17.0.0-next.0 <=18.2.14) Commands are suggestions: review each one before running it.
Loading voting…