Glances's Browser API Exposes Reusable Downstream Credentials via /api/4/serverslist
CVE-2026-32633GHSA-r297-p3v4-wp8m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (glances 4.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI glances
- Affected
- < 4.5.2
- Fixed in
- 4.5.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r297-p3v4-wp8m lists affected ranges: PyPI glances >=0 <=4.5.2-dev01
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r297-p3v4-wp8m lists affected ranges: PyPI glances >=0 <4.5.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r297-p3v4-wp8m lists affected ranges: PyPI glances >=0 <=4.5.2.dev1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-32633: 0.49% estimated exploitation activity in the next 30 days; percentile 42.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary In Central Browser mode, the `/api/4/serverslist` endpoint returns raw server objects from `GlancesServersList.get_servers_list()`. Those objects are mutated in-place during background polling and can contain a `uri` field with embedded HTTP Basic credentials for downstream Glances servers, using the reusable pbkdf2-derived Glances authentication secret. If the front Glances Browser/API instance is started without `--password`, which is supported and common for internal network deployments, `/api/4/serverslist` is completely unauthenticated. Any network user who can reach the Browser API can retrieve reusable credentials for protected downstream Glances servers once they have been polled by the browser instance.
Details The Browser API route simply returns the raw servers list: ```python
glances/outputs/glances_restful_api.py:799-805 def _api_servers_list(self): self.__update_servers_list() return GlancesJSONResponse(self.servers_list.get_servers_list() if…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from osv record GHSA-r297-p3v4-wp8m
- Revision 4 · amended ·
Amended from ghsa record GHSA-r297-p3v4-wp8m
- Revision 3 · amended ·
Amended from ghsa record GHSA-r297-p3v4-wp8m
- Revision 2 · amended ·
Amended from osv record GHSA-r297-p3v4-wp8m
- Revision 1 · created ·
Published from ghsa record GHSA-r297-p3v4-wp8m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32633 Advisory: Glances's Browser API Exposes Reusable Downstream Credentials via `/api/4/serverslist` IDs: CVE-2026-32633, GHSA-r297-p3v4-wp8m Record: https://patchnext.com/advisories/cve-2026-32633 (revision 5, source checked 28 Oct 2026, 06:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: glances 4.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI glances: affected < 4.5.2; fixed in 4.5.2 ## Suggested inspection (read-only) - `python -m pip show glances`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on glances. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r297-p3v4-wp8m (GitHub-reviewed advisory GHSA-r297-p3v4-wp8m lists affected ranges: PyPI glances >=0 <=4.5.2-dev01) - Verified: https://osv.dev/vulnerability/GHSA-r297-p3v4-wp8m (OSV record GHSA-r297-p3v4-wp8m lists affected ranges: PyPI glances >=0 <4.5.2 (fixed)) - Verified: https://github.com/advisories/GHSA-r297-p3v4-wp8m (GitHub-reviewed advisory GHSA-r297-p3v4-wp8m lists affected ranges: PyPI glances >=0 <=4.5.2.dev1) Commands are suggestions: review each one before running it.
Loading voting…