Skip to content

← Actionable
Medium, CVSS 5.3amended

file-type: ZIP Decompression Bomb DoS via [Content_Types].xml entry

CVE-2026-32630GHSA-j47w-4g3g-c36v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (file-type 21.3.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm file-type

    Affected
    >= 20.0.0, <= 21.3.1
    Fixed in
    21.3.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-32630: 0.32% estimated exploitation activity in the next 30 days; percentile 24.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A crafted ZIP file can trigger excessive memory growth during type detection in file-type when using fileTypeFromBuffer(), fileTypeFromBlob(), or fileTypeFromFile(). In affected versions, the ZIP inflate output limit is enforced for stream-based detection, but not for known-size inputs. As a result, a small compressed ZIP can cause file-type to inflate and process a much larger payload while probing ZIP-based formats such as OOXML. In testing on file-type 21.3.1, a ZIP of about 255 KB caused about 257 MB of RSS growth during fileTypeFromBuffer(). This is an availability issue. Applications that use these APIs on untrusted uploads can be forced to consume large amounts of memory and may become slow or crash. Root Cause The ZIP detection logic applied different limits depending on whether the tokenizer had a known file size. For stream inputs, ZIP probing was bounded by maximumZipEntrySizeInBytes (1 MiB). For known-size inputs such as buffers, blobs, and files, the code instead…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-j47w-4g3g-c36v

  2. Revision 1 · created ·

    Published from osv record GHSA-j47w-4g3g-c36v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32630

Advisory: file-type: ZIP Decompression Bomb DoS via [Content_Types].xml entry
IDs: CVE-2026-32630, GHSA-j47w-4g3g-c36v
Record: https://patchnext.com/advisories/cve-2026-32630 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: file-type 21.3.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm file-type: affected >= 20.0.0, <= 21.3.1; fixed in 21.3.2

## Suggested inspection (read-only)
- `npm ls file-type --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on file-type.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j47w-4g3g-c36v (OSV record GHSA-j47w-4g3g-c36v lists affected ranges: npm file-type >=20.0.0 <21.3.2 (fixed))
- Verified: https://github.com/advisories/GHSA-j47w-4g3g-c36v (GitHub-reviewed advisory GHSA-j47w-4g3g-c36v lists affected ranges: npm file-type >=20.0.0 <=21.3.1)

Commands are suggestions: review each one before running it.

Loading voting…