Skip to content

← Actionable
Critical, CVSS 9.9amended

Apollo Federation vulnerable to prototype pollution via incomplete key sanitization

CVE-2026-32621GHSA-pfjj-6f4p-rvmh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@apollo/federation-internals 2.13.2, 2.12.3, 2.11.6, 2.10.5, 2.9.6; @apollo/query-planner 2.13.2, 2.12.3, 2.11.6, 2.10.5, 2.9.6; @apollo/gateway 2.13.2, 2.12.3, 2.11.6, 2.10.5, 2.9.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @apollo/federation-internals

    Affected
    < 2.9.6>= 2.10.0, < 2.10.5>= 2.11.0, < 2.11.6>= 2.12.0, < 2.12.3>= 2.13.0, < 2.13.2
    Fixed in
    2.11.6, 2.10.5, 2.9.6, 2.12.3, 2.13.2
  • npm @apollo/query-planner

    Affected
    < 2.9.6>= 2.10.0, < 2.10.5>= 2.11.0, < 2.11.6>= 2.12.0, < 2.12.3>= 2.13.0, < 2.13.2
    Fixed in
    2.11.6, 2.10.5, 2.9.6, 2.12.3, 2.13.2
  • npm @apollo/gateway

    Affected
    < 2.9.6>= 2.10.0, < 2.10.5>= 2.11.0, < 2.11.6>= 2.12.0, < 2.12.3>= 2.13.0, < 2.13.2
    Fixed in
    2.11.6, 2.10.5, 2.9.6, 2.12.3, 2.13.2

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-pfjj-6f4p-rvmh lists affected ranges: npm @apollo/federation-internals >=0 =2.10.0 =2.11.0 =2.12.0 =2.13.0 =0 =2.10.0 =2.11.0 =2.12.0 =2.13.0 =0 =2.10.0 =2.11.0 =2.12.0 =2.13.0 <2.13.2

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

  • Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database

    OSV record GHSA-pfjj-6f4p-rvmh lists affected ranges: npm @apollo/federation-internals >=0 =2.10.0 =2.11.0 =2.12.0 =2.13.0 =0 =2.10.0 =2.11.0 =2.12.0 =2.13.0 =0 =2.10.0 =2.11.0 =2.12.0 =2.13.0 <2.13.2…

    VerifiedObserved Structured OSV record; GitHub-reviewed advisory.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:L
EPSS
  • CVE-2026-32621: 0.54% estimated exploitation activity in the next 30 days; percentile 45.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A vulnerability exists in query plan execution within the gateway that may allow pollution of Object.prototype in certain scenarios. A malicious client may be able to pollute Object.prototype in gateway directly by crafting operations with field aliases and/or variable names that target prototype-inheritable properties. Alternatively, if a subgraph were to be compromised by a malicious actor, they may be able to pollute Object.prototype in gateway by crafting JSON response payloads that target prototype-inheritable properties. Because Object.prototype is shared across the Node.js process, successful exploitation can affect subsequent requests to the gateway instance. This may result in unexpected application behavior, privilege escalation, data integrity issues, or other security impact depending on how polluted properties are subsequently consumed by the application or its dependencies. As of the date of this advisory, Apollo is not aware of any reported exploitation of this…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-pfjj-6f4p-rvmh

  2. Revision 2 · amended ·

    Amended from osv record GHSA-pfjj-6f4p-rvmh

  3. Revision 1 · created ·

    Published from ghsa record GHSA-pfjj-6f4p-rvmh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32621

Advisory: Apollo Federation vulnerable to prototype pollution via incomplete key sanitization
IDs: CVE-2026-32621, GHSA-pfjj-6f4p-rvmh
Record: https://patchnext.com/advisories/cve-2026-32621 (revision 3, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @apollo/federation-internals 2.13.2, 2.12.3, 2.11.6, 2.10.5, 2.9.6; @apollo/query-planner 2.13.2, 2.12.3, 2.11.6, 2.10.5, 2.9.6; @apollo/gateway 2.13.2, 2.12.3, 2.11.6, 2.10.5, 2.9.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @apollo/federation-internals: affected < 2.9.6; >= 2.10.0, < 2.10.5; >= 2.11.0, < 2.11.6; >= 2.12.0, < 2.12.3; >= 2.13.0, < 2.13.2; fixed in 2.11.6, 2.10.5, 2.9.6, 2.12.3, 2.13.2
- npm @apollo/query-planner: affected < 2.9.6; >= 2.10.0, < 2.10.5; >= 2.11.0, < 2.11.6; >= 2.12.0, < 2.12.3; >= 2.13.0, < 2.13.2; fixed in 2.11.6, 2.10.5, 2.9.6, 2.12.3, 2.13.2
- npm @apollo/gateway: affected < 2.9.6; >= 2.10.0, < 2.10.5; >= 2.11.0, < 2.11.6; >= 2.12.0, < 2.12.3; >= 2.13.0, < 2.13.2; fixed in 2.11.6, 2.10.5, 2.9.6, 2.12.3, 2.13.2

## Suggested inspection (read-only)
- `npm ls @apollo/federation-internals --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @apollo/query-planner --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @apollo/gateway --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @apollo/federation-internals, @apollo/query-planner, @apollo/gateway.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pfjj-6f4p-rvmh (GitHub-reviewed advisory GHSA-pfjj-6f4p-rvmh lists affected ranges: npm @apollo/federation-internals >=0 =2.10.0 =2.11.0 =2.12.0 =2.13.0 =0 =2.10.0 =2.11.0 =2.12.0 =2.13.0 =0 =2.10.0 =2.11.0 =2.12.0 =2.13.0 <2.13.2)
- Verified: https://osv.dev/vulnerability/GHSA-pfjj-6f4p-rvmh (OSV record GHSA-pfjj-6f4p-rvmh lists affected ranges: npm @apollo/federation-internals >=0 =2.10.0 =2.11.0 =2.12.0 =2.13.0 =0 =2.10.0 =2.11.0 =2.12.0 =2.13.0 =0 =2.10.0 =2.11.0 =2.12.0 =2.13.0 <2.13.2…)

Commands are suggestions: review each one before running it.

Loading voting…