Skip to content

← Actionable
Critical, CVSS 9.2

SM9 Infinity-Point Ciphertext Forgery Vulnerability

CVE-2026-32614GHSA-5xxp-2vrj-x855

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/emmansun/gmsm 0.41.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:L/SI:H/SA:N · score source
EPSS
  • CVE-2026-32614: 0.22% estimated exploitation activity in the next 30 days; percentile 13.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview The current SM9 decryption implementation contains an infinity-point ciphertext forgery vulnerability. The root cause is that, during decryption, the elliptic-curve point C1 in the ciphertext is only deserialized and checked to be on the curve, but the implementation does not explicitly reject the point at infinity. In the current implementation, an attacker can construct C1 as the point at infinity, causing the bilinear pairing result to degenerate into the identity element in the GT group. As a result, a critical part of the key derivation input becomes a predictable constant. An attacker who only knows the target user's UID can derive the decryption key material and then forge a ciphertext that passes the integrity check. Impact The direct impact of this vulnerability is ciphertext forgery, not confidentiality loss. - The attacker does not need the master public key, the user's private key, or any other secret material. - The attacker only needs to know the target UID to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5xxp-2vrj-x855

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32614

Advisory: SM9 Infinity-Point Ciphertext Forgery Vulnerability
IDs: CVE-2026-32614, GHSA-5xxp-2vrj-x855
Record: https://patchnext.com/advisories/cve-2026-32614 (revision 1, source checked 26 Oct 2026, 15:18 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/emmansun/gmsm 0.41.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/emmansun/gmsm: affected < 0.41.1; fixed in 0.41.1

## Suggested inspection (read-only)
- Go github.com/emmansun/gmsm: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/emmansun/gmsm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5xxp-2vrj-x855 (GitHub-reviewed advisory GHSA-5xxp-2vrj-x855 lists affected ranges: Go github.com/emmansun/gmsm >=0 <0.41.1)

Commands are suggestions: review each one before running it.

Loading voting…