Spinnaker: RCE via expression parsing due to unrestricted context handling
CVE-2026-32613GHSA-69rw-45wj-g4v6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.spinnaker.echo:echo-pipelinetriggers 2026.0.1, 2025.4.2, 2025.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.spinnaker.echo:echo-pipelinetriggers
- Affected
- >= 2026.0-0, < 2026.0.1>= 2025.4-0, < 2025.4.2< 2025.3.2
- Fixed in
- 2026.0.1, 2025.3.2, 2025.4.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-69rw-45wj-g4v6 lists affected ranges: Maven io.spinnaker.echo:echo-pipelinetriggers >=2026.0-0 =2025.4-0 =0 <2025.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-32613: 0.55% estimated exploitation activity in the next 30 days; percentile 46.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Spinnaker is an open source, multi-cloud continuous delivery platform. Echo like some other services, uses SPeL (Spring Expression Language) to process information - specifically around expected artifacts. In versions prior to 2026.1.0, 2026.0.1, 2025.4.2, and 2025.3.2, unlike orca, it was NOT restricting that context to a set of trusted classes, but allowing FULL JVM access. This enabled a user to use arbitrary java classes which allow deep access to the system. This enabled the ability to invoke commands, access files, etc. Versions 2026.1.0, 2026.0.1, 2025.4.2, and 2025.3.2 contain a patch. As a workaround, disable echo entirely.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-69rw-45wj-g4v6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32613 Advisory: Spinnaker: RCE via expression parsing due to unrestricted context handling IDs: CVE-2026-32613, GHSA-69rw-45wj-g4v6 Record: https://patchnext.com/advisories/cve-2026-32613 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.spinnaker.echo:echo-pipelinetriggers 2026.0.1, 2025.4.2, 2025.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.spinnaker.echo:echo-pipelinetriggers: affected >= 2026.0-0, < 2026.0.1; >= 2025.4-0, < 2025.4.2; < 2025.3.2; fixed in 2026.0.1, 2025.3.2, 2025.4.2 ## Suggested inspection (read-only) - Maven io.spinnaker.echo:echo-pipelinetriggers: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.spinnaker.echo:echo-pipelinetriggers. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-69rw-45wj-g4v6 (GitHub-reviewed advisory GHSA-69rw-45wj-g4v6 lists affected ranges: Maven io.spinnaker.echo:echo-pipelinetriggers >=2026.0-0 =2025.4-0 =0 <2025.3.2) Commands are suggestions: review each one before running it.
Loading voting…