Statamic vulnerable to privilege escalation via stored cross-site scripting
CVE-2026-32612GHSA-hcch-w73c-jp4m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (statamic/cms 6.6.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist statamic/cms
- Affected
- >= 6.0.0, < 6.6.2
- Fixed in
- 6.6.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hcch-w73c-jp4m lists affected ranges: Packagist statamic/cms >=6.0.0 <6.6.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-32612: 0.24% estimated exploitation activity in the next 30 days; percentile 15.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Stored XSS in the control panel color mode preference allows authenticated users with control panel access to inject malicious JavaScript that executes when a higher-privileged user impersonates their account. Patches This has been fixed in 6.6.2.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hcch-w73c-jp4m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32612 Advisory: Statamic vulnerable to privilege escalation via stored cross-site scripting IDs: CVE-2026-32612, GHSA-hcch-w73c-jp4m Record: https://patchnext.com/advisories/cve-2026-32612 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: statamic/cms 6.6.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist statamic/cms: affected >= 6.0.0, < 6.6.2; fixed in 6.6.2 ## Suggested inspection (read-only) - Packagist statamic/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on statamic/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hcch-w73c-jp4m (GitHub-reviewed advisory GHSA-hcch-w73c-jp4m lists affected ranges: Packagist statamic/cms >=6.0.0 <6.6.2) Commands are suggestions: review each one before running it.
Loading voting…