Skip to content

← Actionable
High, CVSS 8.1amended

Glances's Default CORS Configuration Allows Cross-Origin Credential Theft

CVE-2026-32610GHSA-9jfm-9rc6-2hfq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (glances 4.5.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI glances

    Affected
    < 4.5.2
    Fixed in
    4.5.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-32610: 0.34% estimated exploitation activity in the next 30 days; percentile 28.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Glances REST API web server ships with a default CORS configuration that sets alloworigins=[""] combined with allowcredentials=True. When both of these options are enabled together, Starlette's CORSMiddleware reflects the requesting Origin header value in the Access-Control-Allow-Origin response header instead of returning the literal wildcard. This effectively grants any website the ability to make credentialed cross-origin API requests to the Glances server, enabling cross-site data theft of system monitoring information, configuration secrets, and command line arguments from any user who has an active browser session with a Glances instance. Details The CORS configuration is set up in glances/outputs/glancesrestfulapi.py lines 290-299: The defaults are loaded from the config file, but when no config is provided (which is the common case for most deployments), the defaults are: - corsorigins = [""] (all origins) - corscredentials = True (allow credentials) Per the CORS…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9jfm-9rc6-2hfq

  2. Revision 1 · created ·

    Published from osv record GHSA-9jfm-9rc6-2hfq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32610

Advisory: Glances's Default CORS Configuration Allows Cross-Origin Credential Theft
IDs: CVE-2026-32610, GHSA-9jfm-9rc6-2hfq
Record: https://patchnext.com/advisories/cve-2026-32610 (revision 2, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: glances 4.5.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI glances: affected < 4.5.2; fixed in 4.5.2

## Suggested inspection (read-only)
- `python -m pip show glances`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on glances.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9jfm-9rc6-2hfq (OSV record GHSA-9jfm-9rc6-2hfq lists affected ranges: PyPI glances >=0 <4.5.2 (fixed))
- Verified: https://github.com/advisories/GHSA-9jfm-9rc6-2hfq (GitHub-reviewed advisory GHSA-9jfm-9rc6-2hfq lists affected ranges: PyPI glances >=0 <4.5.2)

Commands are suggestions: review each one before running it.

Loading voting…