Skip to content

← Actionable
High, CVSS 7.0amended

Glances has a Command Injection via Process Names in Action Command Templates

CVE-2026-32608GHSA-vcv2-q258-wrg7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (glances 4.5.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI glances

    Affected
    < 4.5.2
    Fixed in
    4.5.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.0 · CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-32608: 0.25% estimated exploitation activity in the next 30 days; percentile 16.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Glances action system allows administrators to configure shell commands that execute when monitoring thresholds are exceeded. These commands support Mustache template variables (e.g., {{name}}, {{key}}) that are populated with runtime monitoring data. The securepopen() function, which executes these commands, implements its own pipe, redirect, and chain operator handling by splitting the command string before passing each segment to subprocess.Popen(shell=False). When a Mustache-rendered value (such as a process name, filesystem mount point, or container name) contains pipe, redirect, or chain metacharacters, the rendered command is split in unintended ways, allowing an attacker who controls a process name or container name to inject arbitrary commands. Details The action execution flow: 1. Admin configures an action in glances.conf (documented feature): 2. When the threshold is exceeded, the plugin model renders the template with runtime stats…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vcv2-q258-wrg7

  2. Revision 1 · created ·

    Published from osv record GHSA-vcv2-q258-wrg7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32608

Advisory: Glances has a Command Injection via Process Names in Action Command Templates
IDs: CVE-2026-32608, GHSA-vcv2-q258-wrg7
Record: https://patchnext.com/advisories/cve-2026-32608 (revision 2, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: glances 4.5.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI glances: affected < 4.5.2; fixed in 4.5.2

## Suggested inspection (read-only)
- `python -m pip show glances`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on glances.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vcv2-q258-wrg7 (OSV record GHSA-vcv2-q258-wrg7 lists affected ranges: PyPI glances >=0 <4.5.2 (fixed))
- Verified: https://github.com/advisories/GHSA-vcv2-q258-wrg7 (GitHub-reviewed advisory GHSA-vcv2-q258-wrg7 lists affected ranges: PyPI glances >=0 <4.5.2)

Commands are suggestions: review each one before running it.

Loading voting…