Skip to content

← Actionable
High, CVSS 7.5amended

PyJWT accepts unknown crit header extensions

CVE-2026-32597GHSA-752w-5fwx-jx9f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyjwt 2.12.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyjwt

    Affected
    <= 2.11.0
    Fixed in
    2.12.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-32597: 0.28% estimated exploitation activity in the next 30 days; percentile 20.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary PyJWT does not validate the crit (Critical) Header Parameter defined in RFC 7515 §4.1.11. When a JWS token contains a crit array listing extensions that PyJWT does not understand, the library accepts the token instead of rejecting it. This violates the MUST requirement in the RFC. This is the same class of vulnerability as CVE-2025-59420 (Authlib), which received CVSS 7.5 (HIGH). --- RFC Requirement RFC 7515 §4.1.11: The "crit" (Critical) Header Parameter indicates that extensions to this specification and/or [JWA] are being used that MUST be understood and processed. [...] If any of the listed extension Header Parameters are not understood and supported by the recipient, then the JWS is invalid. --- Proof of Concept Expected: jwt.exceptions.InvalidTokenError: Unsupported critical extension: x-custom-policy Actual: Token accepted, payload returned. Comparison with RFC-compliant library --- Impact - Split-brain verification in mixed-library deployments (e.g., API gateway using…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-752w-5fwx-jx9f

  2. Revision 1 · created ·

    Published from osv record GHSA-752w-5fwx-jx9f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32597

Advisory: PyJWT accepts unknown `crit` header extensions
IDs: CVE-2026-32597, GHSA-752w-5fwx-jx9f
Record: https://patchnext.com/advisories/cve-2026-32597 (revision 2, source checked 26 Oct 2026, 13:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyjwt 2.12.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyjwt: affected <= 2.11.0; fixed in 2.12.0

## Suggested inspection (read-only)
- `python -m pip show pyjwt`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyjwt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-752w-5fwx-jx9f (OSV record GHSA-752w-5fwx-jx9f lists affected ranges: PyPI pyjwt >=0 <2.12.0 (fixed))
- Verified: https://github.com/advisories/GHSA-752w-5fwx-jx9f (GitHub-reviewed advisory GHSA-752w-5fwx-jx9f lists affected ranges: PyPI pyjwt >=0 <=2.11.0)

Commands are suggestions: review each one before running it.

Loading voting…