Skip to content

← Actionable
High, CVSS 8.7amended

Glances exposes the REST API without authentication

CVE-2026-32596GHSA-wvxv-4j8q-4wjq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (glances 4.5.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI glances

    Affected
    < 4.5.2
    Fixed in
    4.5.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-32596: 1.55% estimated exploitation activity in the next 30 days; percentile 75.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Glances web server runs without authentication by default when started with glances -w, exposing REST API with sensitive system information including process command-lines containing credentials (passwords, API keys, tokens) to any network client. Details Root Cause: Authentication is optional and disabled by default. When no password is provided, the API router initializes without authentication dependency, and the server binds to 0.0.0.0 exposing all endpoints. Affected Code: - File: glances/outputs/glancesrestfulapi.py, lines 259-272 - File: glances/outputs/glancesrestfulapi.py, lines 477-480 - File: glances/outputs/glancesrestfulapi.py, lines 98-99 - File: glances/plugins/processlist/init.py, lines 127-140 PoC 1. Start Glances in default web server mode: 2. Access API without authentication from any network client: <img width="593" height="265" alt="image" src="https://github.com/user-attachments/assets/4ec461be-b480-46d5-88e2-f4004f4dae54" / 3. Extract system…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-wvxv-4j8q-4wjq

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-wvxv-4j8q-4wjq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32596

Advisory: Glances exposes the REST API without authentication
IDs: CVE-2026-32596, GHSA-wvxv-4j8q-4wjq
Record: https://patchnext.com/advisories/cve-2026-32596 (revision 3, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: glances 4.5.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI glances: affected < 4.5.2; fixed in 4.5.2

## Suggested inspection (read-only)
- `python -m pip show glances`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on glances.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wvxv-4j8q-4wjq (OSV record GHSA-wvxv-4j8q-4wjq lists affected ranges: PyPI glances >=0 <4.5.2 (fixed))
- Verified: https://github.com/advisories/GHSA-wvxv-4j8q-4wjq (GitHub-reviewed advisory GHSA-wvxv-4j8q-4wjq lists affected ranges: PyPI glances >=0 <4.5.2)

Commands are suggestions: review each one before running it.

Loading voting…