Skip to content

← Actionable
Medium, CVSS 6.9amended

Parse Server's GraphQL WebSocket endpoint bypasses security middleware

CVE-2026-32594GHSA-p2x3-8689-cwpg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.6.0-alpha.14, 8.6.40), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    >= 9.0.0, < 9.6.0-alpha.14< 8.6.40
    Fixed in
    9.6.0-alpha.14, 8.6.40

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-32594: 0.36% estimated exploitation activity in the next 30 days; percentile 30.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Any Parse Server deployment that uses the GraphQL API is affected. The GraphQL WebSocket endpoint for subscriptions does not pass requests through the Express middleware chain that enforces authentication, introspection control, and query complexity limits. An attacker can connect to the WebSocket endpoint and execute GraphQL operations without providing a valid application or API key, access the GraphQL schema via introspection even when public introspection is disabled, and send arbitrarily complex queries that bypass configured complexity limits. Patches The unfinished GraphQL WebSocket subscription feature has been removed, including the createSubscriptions method and the subscriptions-transport-ws dependency. GraphQL subscriptions were never functional in Parse Server as the schema did not define any subscription types. Workarounds Block WebSocket upgrade requests to the GraphQL subscriptions path (by default /subscriptions) at the network level, for example using a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-p2x3-8689-cwpg

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-p2x3-8689-cwpg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32594

Advisory: Parse Server's GraphQL WebSocket endpoint bypasses security middleware
IDs: CVE-2026-32594, GHSA-p2x3-8689-cwpg
Record: https://patchnext.com/advisories/cve-2026-32594 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 9.6.0-alpha.14, 8.6.40. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected >= 9.0.0, < 9.6.0-alpha.14; < 8.6.40; fixed in 9.6.0-alpha.14, 8.6.40

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p2x3-8689-cwpg (OSV record GHSA-p2x3-8689-cwpg lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.40 (fixed))
- Verified: https://github.com/advisories/GHSA-p2x3-8689-cwpg (GitHub-reviewed advisory GHSA-p2x3-8689-cwpg lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.40)

Commands are suggestions: review each one before running it.

Loading voting…