Winter: SQL Injection in Backend Filter Widget numberrange Scope via numbersFromAjax
CVE-2026-32593GHSA-m7jc-g4rc-jmvh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (winter/wn-backend-module 1.2.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist winter/wn-backend-module
- Affected
- <= 1.2.12
- Fixed in
- 1.2.13
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m7jc-g4rc-jmvh lists affected ranges: Packagist winter/wn-backend-module >=0 <1.2.13 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m7jc-g4rc-jmvh lists affected ranges: Packagist winter/wn-backend-module >=0 <=1.2.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-32593: 0.27% estimated exploitation activity in the next 30 days; percentile 19.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Backend Filter widget (Backend\Widgets\Filter) is vulnerable to SQL injection through the numberrange scope type when the scope is configured with a conditions key. An authenticated backend user with access to a list view containing a vulnerable filter scope can inject arbitrary SQL via the filter's AJAX handler, potentially gaining read access to the full database contents. To exploit this, an attacker must have a valid backend account with access to a list view where a third-party plugin has registered a numberrange filter scope using the conditions configuration key. No built-in Winter CMS backend views use this scope type and configuration combination, so a vanilla installation without plugins is not exploitable. Patches This issue has been fixed in Winter CMS v1.2.13. Workarounds If users cannot upgrade, they may apply commit https://github.com/wintercms/winter/commit/50713de95adf5298536d93f4d999652525d36d43 to your Winter CMS installation manually to resolve this…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-m7jc-g4rc-jmvh
- Revision 1 · created ·
Published from osv record GHSA-m7jc-g4rc-jmvh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32593 Advisory: Winter: SQL Injection in Backend Filter Widget numberrange Scope via numbersFromAjax IDs: CVE-2026-32593, GHSA-m7jc-g4rc-jmvh Record: https://patchnext.com/advisories/cve-2026-32593 (revision 2, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: winter/wn-backend-module 1.2.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist winter/wn-backend-module: affected <= 1.2.12; fixed in 1.2.13 ## Suggested inspection (read-only) - Packagist winter/wn-backend-module: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on winter/wn-backend-module. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m7jc-g4rc-jmvh (OSV record GHSA-m7jc-g4rc-jmvh lists affected ranges: Packagist winter/wn-backend-module >=0 <1.2.13 (fixed)) - Verified: https://github.com/advisories/GHSA-m7jc-g4rc-jmvh (GitHub-reviewed advisory GHSA-m7jc-g4rc-jmvh lists affected ranges: Packagist winter/wn-backend-module >=0 <=1.2.12) Commands are suggestions: review each one before running it.
Loading voting…