Skip to content

← Actionable
Medium, CVSS 6.5

Ella Core: AMF DoS via malformed PathSwitchRequest with empty NR security capability bitstrings

CVE-2026-32320GHSA-j478-p7vq-3347

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/ellanetworks/core 1.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-32320: 0.19% estimated exploitation activity in the next 30 days; percentile 8.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Ella Core panics when processing a PathSwitchRequest containing UE Security Capabilities with zero-length NR encryption or integrity protection algorithm bitstrings, resulting in a denial of service. Impact An attacker able to send crafted NGAP messages to Ella Core can crash the process, causing service disruption for all connected subscribers. No authentication is required. Fix Added length validation on NR algorithm bitstrings before accessing them in the PathSwitchRequest handler.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j478-p7vq-3347

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32320

Advisory: Ella Core: AMF DoS via malformed PathSwitchRequest with empty NR security capability bitstrings
IDs: CVE-2026-32320, GHSA-j478-p7vq-3347
Record: https://patchnext.com/advisories/cve-2026-32320 (revision 1, source checked 26 Oct 2026, 15:18 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/ellanetworks/core 1.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/ellanetworks/core: affected < 1.5.1; fixed in 1.5.1

## Suggested inspection (read-only)
- Go github.com/ellanetworks/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/ellanetworks/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j478-p7vq-3347 (GitHub-reviewed advisory GHSA-j478-p7vq-3347 lists affected ranges: Go github.com/ellanetworks/core >=0 <1.5.1)

Commands are suggestions: review each one before running it.

Loading voting…