Skip to content

← Actionable
Medium, CVSS 5.5amended

motionEye's World-Readable Configuration File Exposes Admin Password Hash

CVE-2026-32315GHSA-rhgp-6wq6-9j67

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (motioneye 0.44.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-32315: 1.68% estimated exploitation activity in the next 30 days; percentile 76.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Security Advisory: World-Readable Configuration File Exposes Admin Password Hash in motionEye Summary motionEye v0.43.1 and prior versions create the configuration file /etc/motioneye/motion.conf with 644 permissions (-rw-r--r--), making it readable by any local user on the system. This file contains sensitive data including the admin password hash, which can be leveraged by other vulnerabilities to escalate privileges. Affected Versions - motionEye <= 0.43.1b4 - Fixed in motionEye 0.44.0b1 (applies 0600 mode to motion.conf and camera-.conf files) Vulnerability Details World-Readable Configuration File (CWE-732) When motionEye writes its configuration, the file /etc/motioneye/motion.conf is created with 644 permissions regardless of the installation method. This file contains the admin password hash in the @adminpassword field: Any local user can read this hash without elevated privileges: Additionally, per-camera configuration files (camera-.conf) are also created with the same 644…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rhgp-6wq6-9j67

  2. Revision 1 · created ·

    Published from osv record GHSA-rhgp-6wq6-9j67

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32315

Advisory: motionEye's World-Readable Configuration File Exposes Admin Password Hash
IDs: CVE-2026-32315, GHSA-rhgp-6wq6-9j67
Record: https://patchnext.com/advisories/cve-2026-32315 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: motioneye 0.44.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI motioneye: affected < 0.44.0; fixed in 0.44.0

## Suggested inspection (read-only)
- `python -m pip show motioneye`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on motioneye.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rhgp-6wq6-9j67 (OSV record GHSA-rhgp-6wq6-9j67 lists affected ranges: PyPI motioneye >=0 <0.44.0 (fixed))
- Verified: https://github.com/advisories/GHSA-rhgp-6wq6-9j67 (GitHub-reviewed advisory GHSA-rhgp-6wq6-9j67 lists affected ranges: PyPI motioneye >=0 <0.44.0)

Commands are suggestions: review each one before running it.

Loading voting…