Locutus vulnerable to RCE via unsanitized input in create_function()
CVE-2026-32304GHSA-vh9h-29pq-r5m8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (locutus 3.0.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm locutus
- Affected
- <= 3.0.13
- Fixed in
- 3.0.14
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vh9h-29pq-r5m8 lists affected ranges: npm locutus >=0 <=3.0.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vh9h-29pq-r5m8 lists affected ranges: npm locutus >=0 <3.0.14 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-32304: 0.59% estimated exploitation activity in the next 30 days; percentile 48.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The createfunction(args, code) function passes both parameters directly to the Function constructor without any sanitization, allowing arbitrary code execution. This is distinct from CVE-2026-29091 (GHSA-fp25-p6mj-qqg6) which was calluserfuncarray using eval() in v2.x. This finding affects createfunction using new Function() in v3.x. Root Cause src/php/funchand/createfunction.ts:17: Zero input validation on either parameter. PoC Confirmed on locutus v3.0.11, Node.js v24.13.1. Impact Full RCE when an attacker can control either argument to createfunction(). 597K weekly npm downloads. Suggested Fix Remove createfunction or replace new Function() with a safe alternative. PHP itself deprecated createfunction() in PHP 7.2 for the same reason. Response Thanks for the report. We confirmed that php/funchand/createfunction was still present through locutus@3.0.13 and that it exposed dynamic code execution via new Function(...). While this was intended behavior, createfunction()…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vh9h-29pq-r5m8
- Revision 2 · amended ·
Amended from osv record GHSA-vh9h-29pq-r5m8
- Revision 1 · created ·
Published from ghsa record GHSA-vh9h-29pq-r5m8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32304 Advisory: Locutus vulnerable to RCE via unsanitized input in create_function() IDs: CVE-2026-32304, GHSA-vh9h-29pq-r5m8 Record: https://patchnext.com/advisories/cve-2026-32304 (revision 3, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: locutus 3.0.14. A vendor fix does not mean a deployment is fixed. ## Affected components - npm locutus: affected <= 3.0.13; fixed in 3.0.14 ## Suggested inspection (read-only) - `npm ls locutus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on locutus. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vh9h-29pq-r5m8 (GitHub-reviewed advisory GHSA-vh9h-29pq-r5m8 lists affected ranges: npm locutus >=0 <=3.0.13) - Verified: https://osv.dev/vulnerability/GHSA-vh9h-29pq-r5m8 (OSV record GHSA-vh9h-29pq-r5m8 lists affected ranges: npm locutus >=0 <3.0.14 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…