Skip to content

← Actionable
High, CVSS 8.7

Connect-CMS has DOM-based Cross-Site Scripting (XSS) in the Cabinet Plugin List View

CVE-2026-32277GHSA-cmfh-mpmf-fmq4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (opensource-workshop/connect-cms 2.41.1, 1.41.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-32277: 0.33% estimated exploitation activity in the next 30 days; percentile 26.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Security Advisory — Cabinet Plugin (DOM-based XSS) Summary A DOM-based Cross-Site Scripting (XSS) issue exists in the Cabinet Plugin list view. Affected Versions - 1.x series: = 1.35.0, <= 1.41.0 - 2.x series: = 2.35.0, <= 2.41.0 Patched Versions - 1.41.1 - 2.41.1 Description In the Cabinet Plugin list view, DOM-based Cross-Site Scripting (XSS) could occur due to how saved names were rendered. If exploited, arbitrary script could run in the victim's browser, which may lead to unauthorized actions or information theft. Exploitation requires that the attacker be able to reach the affected functionality as an authenticated user. Users affected by this vulnerability should update to a fixed version. Solution Update to the fixed version. For the 1.x series, update to 1.41.1 or later. For the 2.x series, update to 2.41.1 or later. Credits OpenSource WorkShop thanks Sho Odagiri (小田切 祥) of GMO Cybersecurity by Ierae, Inc. for reporting this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cmfh-mpmf-fmq4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32277

Advisory: Connect-CMS has DOM-based Cross-Site Scripting (XSS) in the Cabinet Plugin List View
IDs: CVE-2026-32277, GHSA-cmfh-mpmf-fmq4
Record: https://patchnext.com/advisories/cve-2026-32277 (revision 1, source checked 26 Oct 2026, 14:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: opensource-workshop/connect-cms 2.41.1, 1.41.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist opensource-workshop/connect-cms: affected >= 1.35.0, < 1.41.1; >= 2.35.0, < 2.41.1; fixed in 2.41.1, 1.41.1

## Suggested inspection (read-only)
- Packagist opensource-workshop/connect-cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on opensource-workshop/connect-cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cmfh-mpmf-fmq4 (GitHub-reviewed advisory GHSA-cmfh-mpmf-fmq4 lists affected ranges: Packagist opensource-workshop/connect-cms >=1.35.0 =2.35.0 <2.41.1)

Commands are suggestions: review each one before running it.

Loading voting…