Google Cloud Storage for Craft CMS has an Information Disclosure Vulnerability
CVE-2026-32266GHSA-67cr-jmh8-4jpq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/google-cloud 2.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist craftcms/google-cloud
- Affected
- >= 2.0.0-beta.1, <= 2.2.0
- Fixed in
- 2.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-67cr-jmh8-4jpq lists affected ranges: Packagist craftcms/google-cloud >=2.0.0-beta.1 <=2.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.4 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:H/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2026-32266: 0.36% estimated exploitation activity in the next 30 days; percentile 29.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Unauthenticated users can view a list of buckets the plugin has access to. The DefaultController-actionLoadBucketData() endpoint allows unauthenticated users with a valid CSRF token to view a list of buckets that the plugin is allowed to see. Users should update to version 2.2.1 of the plugin to mitigate the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-67cr-jmh8-4jpq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32266 Advisory: Google Cloud Storage for Craft CMS has an Information Disclosure Vulnerability IDs: CVE-2026-32266, GHSA-67cr-jmh8-4jpq Record: https://patchnext.com/advisories/cve-2026-32266 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: craftcms/google-cloud 2.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist craftcms/google-cloud: affected >= 2.0.0-beta.1, <= 2.2.0; fixed in 2.2.1 ## Suggested inspection (read-only) - Packagist craftcms/google-cloud: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on craftcms/google-cloud. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-67cr-jmh8-4jpq (GitHub-reviewed advisory GHSA-67cr-jmh8-4jpq lists affected ranges: Packagist craftcms/google-cloud >=2.0.0-beta.1 <=2.2.0) Commands are suggestions: review each one before running it.
Loading voting…