Craft CMS vulnerable to behavior injection RCE via EntryTypesController
CVE-2026-32263GHSA-qx2q-q59v-wf3j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.9.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist craftcms/cms
- Affected
- >= 5.6.0, <= 5.9.10
- Fixed in
- 5.9.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qx2q-q59v-wf3j lists affected ranges: Packagist craftcms/cms >=5.6.0 <=5.9.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-32263: 0.53% estimated exploitation activity in the next 30 days; percentile 44.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The fix for GHSA-7jx7-3846-m7w7 (commit 395c64f0b80b507be1c862a2ec942eaacb353748) only patched src/services/Fields.php, but the same vulnerable pattern exists in EntryTypesController::actionApplyOverrideSettings(). In src/controllers/EntryTypesController.php lines 381-387: The $settings array from parsestr is passed directly to Craft::configure() without Component::cleanseConfig(). This allows injecting Yii2 behavior/event handlers via as or on prefixed keys, the same attack vector as the original advisory. You need Craft control panel administrator permissions, and allowAdminChanges must be enabled for this to work. An attacker can use the same gadget chain from the original advisory to achieve RCE. Users should update to Craft 5.9.11 to mitigate the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qx2q-q59v-wf3j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32263 Advisory: Craft CMS vulnerable to behavior injection RCE via EntryTypesController IDs: CVE-2026-32263, GHSA-qx2q-q59v-wf3j Record: https://patchnext.com/advisories/cve-2026-32263 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.9.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist craftcms/cms: affected >= 5.6.0, <= 5.9.10; fixed in 5.9.11 ## Suggested inspection (read-only) - Packagist craftcms/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on craftcms/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qx2q-q59v-wf3j (GitHub-reviewed advisory GHSA-qx2q-q59v-wf3j lists affected ranges: Packagist craftcms/cms >=5.6.0 <=5.9.10) Commands are suggestions: review each one before running it.
Loading voting…