Parse Server: Account takeover via operator injection in authentication data identifier
CVE-2026-32248GHSA-5fw2-8jcv-xh87
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.6.0-alpha.12, 8.6.38), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- >= 9.0.0, < 9.6.0-alpha.12< 8.6.38
- Fixed in
- 8.6.38, 9.6.0-alpha.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5fw2-8jcv-xh87 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.38
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5fw2-8jcv-xh87 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.38 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-32248: 0.64% estimated exploitation activity in the next 30 days; percentile 50.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An unauthenticated attacker can take over any user account that was created with an authentication provider that does not validate the format of the user identifier (e.g. anonymous authentication). By sending a crafted login request, the attacker can cause the server to perform a pattern-matching query instead of an exact-match lookup, allowing the attacker to match an existing user and obtain a valid session token for that user's account. Both MongoDB and PostgreSQL database backends are affected. Any Parse Server deployment that allows anonymous authentication (enabled by default) is vulnerable. Patches The fix enforces that the user identifier in authentication data is a string before using it in a database query. Non-string values are rejected with a validation error. Workarounds There is no known workaround. References - GitHub security advisory: https://github.com/parse-community/parse-server/security/advisories/GHSA-5fw2-8jcv-xh87 - Fix Parse Server 9:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-5fw2-8jcv-xh87
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-5fw2-8jcv-xh87
- Revision 1 · created ·
Published from ghsa record GHSA-5fw2-8jcv-xh87
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32248 Advisory: Parse Server: Account takeover via operator injection in authentication data identifier IDs: CVE-2026-32248, GHSA-5fw2-8jcv-xh87 Record: https://patchnext.com/advisories/cve-2026-32248 (revision 4, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 9.6.0-alpha.12, 8.6.38. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected >= 9.0.0, < 9.6.0-alpha.12; < 8.6.38; fixed in 8.6.38, 9.6.0-alpha.12 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5fw2-8jcv-xh87 (GitHub-reviewed advisory GHSA-5fw2-8jcv-xh87 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.38) - Verified: https://osv.dev/vulnerability/GHSA-5fw2-8jcv-xh87 (OSV record GHSA-5fw2-8jcv-xh87 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.38 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…