Skip to content

← Actionable
High, CVSS 8.1amended

Graphiti vulnerable to Cypher Injection via unsanitized node_labels in search filters

CVE-2026-32247GHSA-gg5m-55jj-8m5g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (graphiti-core 0.28.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-32247: 0.36% estimated exploitation activity in the next 30 days; percentile 29.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Graphiti versions before 0.28.2 contained a Cypher injection vulnerability in shared search-filter construction for non-Kuzu backends. Attacker-controlled label values supplied through SearchFilters.nodelabels were concatenated directly into Cypher label expressions without validation. In MCP deployments, this was exploitable not only through direct untrusted access to the Graphiti MCP server, but also through prompt injection against an LLM client that could be induced to call searchnodes with attacker-controlled entitytypes values. The MCP server mapped entitytypes to SearchFilters.nodelabels, which then reached the vulnerable Cypher construction path. Affected backends included Neo4j, FalkorDB, and Neptune. Kuzu was not affected by the label-injection issue because it used parameterized label handling rather than string-interpolated Cypher labels. This issue was mitigated in 0.28.2. Affected Versions - 0.28.1 and earlier Fixed Version - 0.28.2 Affected Components -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-gg5m-55jj-8m5g

  2. Revision 1 · created ·

    Published from osv record GHSA-gg5m-55jj-8m5g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32247

Advisory: Graphiti vulnerable to Cypher Injection via unsanitized node_labels in search filters
IDs: CVE-2026-32247, GHSA-gg5m-55jj-8m5g
Record: https://patchnext.com/advisories/cve-2026-32247 (revision 2, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: graphiti-core 0.28.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI graphiti-core: affected <= 0.28.1; fixed in 0.28.2

## Suggested inspection (read-only)
- `python -m pip show graphiti-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on graphiti-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gg5m-55jj-8m5g (OSV record GHSA-gg5m-55jj-8m5g lists affected ranges: PyPI graphiti-core >=0 <0.28.2 (fixed))
- Verified: https://github.com/advisories/GHSA-gg5m-55jj-8m5g (GitHub-reviewed advisory GHSA-gg5m-55jj-8m5g lists affected ranges: PyPI graphiti-core >=0 <=0.28.1)

Commands are suggestions: review each one before running it.

Loading voting…