Skip to content

← Actionable
High, CVSS 7.5

Flannel has cross-node remote code execution via extension backend BackendData injection

CVE-2026-32241GHSA-vchx-5pr6-ffx2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/flannel-io/flannel 0.28.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-32241: 2.76% estimated exploitation activity in the next 30 days; percentile 86.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Background The Flannel project includes an experimental Extension backend that allows users to easily prototype new backend types. This backend uses shell commands stored in Kubernetes annotations to configure network connectivity on the node. Note: consumers are only affected by this vulnerability if they use the experimental Extension backend. Other backends such as vxlan and wireguard are unaffected. Vulnerability This Extension backend is vulnerable to a command injection that allows an attacker who can set Kubernetes Node annotations to achieve root-level arbitrary command execution on every flannel node in the cluster. The Extension backend's SubnetAddCommand and SubnetRemoveCommand receive attacker-controlled data via stdin (from the flannel.alpha.coreos.com/backend-data Node annotation). The content of this annotation is unmarshalled and piped directly to a shell command without checks. Impact Kubernetes clusters using Flannel with the Extension backend are affected by this…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vchx-5pr6-ffx2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32241

Advisory: Flannel has cross-node remote code execution via extension backend BackendData injection
IDs: CVE-2026-32241, GHSA-vchx-5pr6-ffx2
Record: https://patchnext.com/advisories/cve-2026-32241 (revision 1, source checked 26 Oct 2026, 15:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/flannel-io/flannel 0.28.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/flannel-io/flannel: affected <= 0.28.1; fixed in 0.28.2

## Suggested inspection (read-only)
- Go github.com/flannel-io/flannel: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/flannel-io/flannel.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vchx-5pr6-ffx2 (GitHub-reviewed advisory GHSA-vchx-5pr6-ffx2 lists affected ranges: Go github.com/flannel-io/flannel >=0 <=0.28.1)

Commands are suggestions: review each one before running it.

Loading voting…