@backstage/plugin-auth-backend: SSRF in experimental CIMD metadata fetch
CVE-2026-32236GHSA-qp4c-xg64-7c6x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-auth-backend 0.27.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @backstage/plugin-auth-backend
- Affected
- < 0.27.1
- Fixed in
- 0.27.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qp4c-xg64-7c6x lists affected ranges: npm @backstage/plugin-auth-backend >=0 <0.27.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qp4c-xg64-7c6x lists affected ranges: npm @backstage/plugin-auth-backend >=0 <0.27.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.7 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2026-32236: 0.31% estimated exploitation activity in the next 30 days; percentile 24.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A Server-Side Request Forgery (SSRF) vulnerability exists in @backstage/plugin-auth-backend when auth.experimentalClientIdMetadataDocuments.enabled is set to true. The CIMD metadata fetch validates the initial clientid hostname against private IP ranges but does not apply the same validation after HTTP redirects. The practical impact is limited. The attacker cannot read the response body from the internal request, cannot control request headers or method, and the feature must be explicitly enabled via an experimental flag that is off by default. Deployments that restrict allowedClientIdPatterns to specific trusted domains are not affected.
Patches Patched in @backstage/plugin-auth-backend version 0.27.1. The fix disables HTTP redirect following when fetching CIMD metadata documents.
Workarounds Disable the experimental CIMD feature by removing or setting auth.experimentalClientIdMetadataDocuments.enabled to false in your app-config. This is the default configuration.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-qp4c-xg64-7c6x
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-qp4c-xg64-7c6x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32236 Advisory: @backstage/plugin-auth-backend: SSRF in experimental CIMD metadata fetch IDs: CVE-2026-32236, GHSA-qp4c-xg64-7c6x Record: https://patchnext.com/advisories/cve-2026-32236 (revision 3, source checked 26 Oct 2026, 12:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-auth-backend 0.27.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @backstage/plugin-auth-backend: affected < 0.27.1; fixed in 0.27.1 ## Suggested inspection (read-only) - `npm ls @backstage/plugin-auth-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @backstage/plugin-auth-backend. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qp4c-xg64-7c6x (OSV record GHSA-qp4c-xg64-7c6x lists affected ranges: npm @backstage/plugin-auth-backend >=0 <0.27.1 (fixed)) - Verified: https://github.com/advisories/GHSA-qp4c-xg64-7c6x (GitHub-reviewed advisory GHSA-qp4c-xg64-7c6x lists affected ranges: npm @backstage/plugin-auth-backend >=0 <0.27.1) Commands are suggestions: review each one before running it.
Loading voting…