Skip to content

← Actionable
Medium, CVSS 5.9amended

@backstage/plugin-auth-backend: OAuth redirect URI allowlist bypass

CVE-2026-32235GHSA-wqvh-63mv-9w92

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-auth-backend 0.27.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:N
EPSS
  • CVE-2026-32235: 0.15% estimated exploitation activity in the next 30 days; percentile 4.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The experimental OIDC provider in @backstage/plugin-auth-backend is vulnerable to a redirect URI allowlist bypass. Instances that have enabled experimental Dynamic Client Registration or Client ID Metadata Documents and configured allowedRedirectUriPatterns are affected. A specially crafted redirect URI can pass the allowlist validation while resolving to an attacker-controlled host. If a victim approves the resulting OAuth consent request, their authorization code is sent to the attacker, who can exchange it for a valid access token. This requires victim interaction and that one of the experimental features is explicitly enabled, which is not the default. Patches Upgrade to @backstage/plugin-auth-backend version 0.27.1 or later. Workarounds Disable experimental Dynamic Client Registration and Client ID Metadata Documents features if they are not required. References - RFC 6749 Section 3.1.2 - Redirection Endpoint

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wqvh-63mv-9w92

  2. Revision 1 · created ·

    Published from osv record GHSA-wqvh-63mv-9w92

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32235

Advisory: @backstage/plugin-auth-backend: OAuth redirect URI allowlist bypass
IDs: CVE-2026-32235, GHSA-wqvh-63mv-9w92
Record: https://patchnext.com/advisories/cve-2026-32235 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-auth-backend 0.27.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @backstage/plugin-auth-backend: affected < 0.27.1; fixed in 0.27.1

## Suggested inspection (read-only)
- `npm ls @backstage/plugin-auth-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @backstage/plugin-auth-backend.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wqvh-63mv-9w92 (OSV record GHSA-wqvh-63mv-9w92 lists affected ranges: npm @backstage/plugin-auth-backend >=0 <0.27.1 (fixed))
- Verified: https://github.com/advisories/GHSA-wqvh-63mv-9w92 (GitHub-reviewed advisory GHSA-wqvh-63mv-9w92 lists affected ranges: npm @backstage/plugin-auth-backend >=0 <0.27.1)

Commands are suggestions: review each one before running it.

Loading voting…