Skip to content

← Actionable
Medium, CVSS 5.1amended

Parse Server has a SQL injection via query field name when using PostgreSQL

CVE-2026-32234GHSA-c442-97qw-j6c6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.6.0-alpha.10, 8.6.36), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    >= 9.0.0, < 9.6.0-alpha.10< 8.6.36
    Fixed in
    9.6.0-alpha.10, 8.6.36

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:L/SI:N/SA:N · score source
EPSS
  • CVE-2026-32234: 0.21% estimated exploitation activity in the next 30 days; percentile 11.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker with access to the master key can inject malicious SQL via crafted field names used in query constraints when Parse Server is configured with PostgreSQL as the database. The field name in a $regex query operator is passed to PostgreSQL using unparameterized string interpolation, allowing the attacker to manipulate the SQL query. While the master key controls what can be done through the Parse Server abstraction layer, this SQL injection bypasses Parse Server entirely and operates at the database level. This vulnerability only affects Parse Server deployments using PostgreSQL. Patches The fix applies proper SQL identifier escaping to field names in the query handler and hardens query field name validation to reject malicious field names for all query types. Workarounds There is no known workaround. References - GitHub security advisory: https://github.com/parse-community/parse-server/security/advisories/GHSA-c442-97qw-j6c6 - Fix Parse Server 9:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-c442-97qw-j6c6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-c442-97qw-j6c6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32234

Advisory: Parse Server has a SQL injection via query field name when using PostgreSQL
IDs: CVE-2026-32234, GHSA-c442-97qw-j6c6
Record: https://patchnext.com/advisories/cve-2026-32234 (revision 3, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 9.6.0-alpha.10, 8.6.36. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected >= 9.0.0, < 9.6.0-alpha.10; < 8.6.36; fixed in 9.6.0-alpha.10, 8.6.36

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c442-97qw-j6c6 (OSV record GHSA-c442-97qw-j6c6 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.36 (fixed))
- Verified: https://github.com/advisories/GHSA-c442-97qw-j6c6 (GitHub-reviewed advisory GHSA-c442-97qw-j6c6 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.36)

Commands are suggestions: review each one before running it.

Loading voting…