Skip to content

← Actionable
Critical, CVSS 9.8

MsQuic has a Remote Elevation of Privilege Vulnerability

CVE-2026-32179GHSA-gvvw-8j96-8g5r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (microsoft.native.quic.msquic.schannel 2.5.7, 2.4.18; microsoft.native.quic.msquic.openssl 2.5.7, 2.4.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-gvvw-8j96-8g5r lists affected ranges: NuGet microsoft.native.quic.msquic.openssl >=2.5.0-ci.532574 =0 =2.5.0-ci.532574 =0 <2.4.18

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary Improper input validation in Microsoft QUIC allows an unauthorized attacker to elevate privileges over a network. Details Improper Input Validation Integer Underflow (Wrap or Wraparound) when decoding ACK frame. Patches - Fix underflow in ACK frame parsing - 1e6e999b Impact An attacker who successfully exploited this vulnerability could gain elevated privileges.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gvvw-8j96-8g5r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32179

Advisory: MsQuic has a Remote Elevation of Privilege Vulnerability
IDs: CVE-2026-32179, GHSA-gvvw-8j96-8g5r
Record: https://patchnext.com/advisories/cve-2026-32179 (revision 1, source checked 26 Oct 2026, 17:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: microsoft.native.quic.msquic.schannel 2.5.7, 2.4.18; microsoft.native.quic.msquic.openssl 2.5.7, 2.4.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet microsoft.native.quic.msquic.schannel: affected >= 2.5.0-ci.532574, < 2.5.7; < 2.4.18; fixed in 2.4.18, 2.5.7
- NuGet microsoft.native.quic.msquic.openssl: affected >= 2.5.0-ci.532574, < 2.5.7; < 2.4.18; fixed in 2.4.18, 2.5.7

## Suggested inspection (read-only)
- NuGet microsoft.native.quic.msquic.schannel: check the installed version with your package manager.
- NuGet microsoft.native.quic.msquic.openssl: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on microsoft.native.quic.msquic.schannel, microsoft.native.quic.msquic.openssl.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gvvw-8j96-8g5r (GitHub-reviewed advisory GHSA-gvvw-8j96-8g5r lists affected ranges: NuGet microsoft.native.quic.msquic.openssl >=2.5.0-ci.532574 =0 =2.5.0-ci.532574 =0 <2.4.18)

Commands are suggestions: review each one before running it.

Loading voting…