Skip to content

← Actionable
High, CVSS 7.5amended

flatted vulnerable to unbounded recursion DoS in parse() revive phase

CVE-2026-32141GHSA-25h7-pfq9-p65f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flatted 3.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm flatted

    Affected
    < 3.4.0
    Fixed in
    3.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-32141: 0.84% estimated exploitation activity in the next 30 days; percentile 57.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary flatted's parse() function uses a recursive revive() phase to resolve circular references in deserialized JSON. When given a crafted payload with deeply nested or self-referential $ indices, the recursion depth is unbounded, causing a stack overflow that crashes the Node.js process. Impact Denial of Service (DoS). Any application that passes untrusted input to flatted.parse() can be crashed by an unauthenticated attacker with a single request. flatted has ~87M weekly npm downloads and is used as the circular-JSON serialization layer in many caching and logging libraries. Proof of Concept Fix The maintainer has already merged an iterative (non-recursive) implementation in PR #88, converting the recursive revive() to a stack-based loop. Affected Versions All versions prior to the PR #88 fix.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-25h7-pfq9-p65f

  2. Revision 1 · created ·

    Published from osv record GHSA-25h7-pfq9-p65f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32141

Advisory: flatted vulnerable to unbounded recursion DoS in parse() revive phase
IDs: CVE-2026-32141, GHSA-25h7-pfq9-p65f
Record: https://patchnext.com/advisories/cve-2026-32141 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flatted 3.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flatted: affected < 3.4.0; fixed in 3.4.0

## Suggested inspection (read-only)
- `npm ls flatted --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flatted.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-25h7-pfq9-p65f (OSV record GHSA-25h7-pfq9-p65f lists affected ranges: npm flatted >=0 <3.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-25h7-pfq9-p65f (GitHub-reviewed advisory GHSA-25h7-pfq9-p65f lists affected ranges: npm flatted >=0 <3.4.0)

Commands are suggestions: review each one before running it.

Loading voting…