Skip to content

← Actionable
Medium, CVSS 6.8amended

ha-mcp has XSS via Unescaped HTML in OAuth Consent Form

CVE-2026-32112GHSA-pf93-j98v-25pv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ha-mcp 7.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ha-mcp

    Affected
    < 7.0.0
    Fixed in
    7.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-32112: 0.19% estimated exploitation activity in the next 30 days; percentile 8.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The ha-mcp OAuth consent form renders user-controlled parameters via Python f-strings with no HTML escaping. An attacker who can reach the OAuth endpoint and convince the server operator to follow a crafted authorization URL could execute JavaScript in the operator's browser. This affects only users running the beta OAuth mode (ha-mcp-oauth), which is not part of the standard setup and requires explicit configuration. Details Unescaped f-string rendering consentform.py builds HTML using Python f-strings. No call to html.escape() exists anywhere in the file. The following values are rendered unescaped: - clientname / clientid — in HTML element context (lines 299, 303) - clientid, redirecturi, state — in HTML attribute context (lines 310–312), where a " character breaks out of value="" - errormessage, error, errordescription — in error display paths (lines 36–40, 496–497) An attacker can register a client with a malicious clientname via the /register (DCR) endpoint, which…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pf93-j98v-25pv

  2. Revision 1 · created ·

    Published from osv record GHSA-pf93-j98v-25pv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32112

Advisory: ha-mcp has XSS via Unescaped HTML in OAuth Consent Form
IDs: CVE-2026-32112, GHSA-pf93-j98v-25pv
Record: https://patchnext.com/advisories/cve-2026-32112 (revision 2, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ha-mcp 7.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ha-mcp: affected < 7.0.0; fixed in 7.0.0

## Suggested inspection (read-only)
- `python -m pip show ha-mcp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ha-mcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pf93-j98v-25pv (OSV record GHSA-pf93-j98v-25pv lists affected ranges: PyPI ha-mcp >=0 <7.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-pf93-j98v-25pv (GitHub-reviewed advisory GHSA-pf93-j98v-25pv lists affected ranges: PyPI ha-mcp >=0 <7.0.0)

Commands are suggestions: review each one before running it.

Loading voting…