Skip to content

← Actionable
Low, CVSS 3.7amended

Copyparty has unexpected JavaScript execution via crafted URL to folder with .prologue.html

CVE-2026-32109GHSA-rcp6-88mm-9vgf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (copyparty 1.20.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI copyparty

    Affected
    < 1.20.12
    Fixed in
    1.20.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-32109: 0.17% estimated exploitation activity in the next 30 days; percentile 6.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

If an attacker has been given both read- and write-permissions to the server, they can upload a malicious file with the filename .prologue.html and then craft a link to potentially execute arbitrary JavaScript in the victim's context. Note that it is intended behavior that the JavaScript would execute if the target clicks a link to the HTML file itself; "https://example.com/foo/.prologue.html". The vulnerability is that "https://example.com/foo/?b" would also evaluate the file, making the behavior unexpected. There are existing preventative measures (strict SameSite cookies) which makes it harder to leverage this vulnerability in an attack; in order to gain control of the target's authenticated session, the link must be clicked from a page served by the server itself -- most likely by editing an existing resource, which would require additional access permissions. Finally, for this attack to be successful, the attacker's target must click the specific crafted link given by the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rcp6-88mm-9vgf

  2. Revision 1 · created ·

    Published from osv record GHSA-rcp6-88mm-9vgf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32109

Advisory: Copyparty has unexpected JavaScript execution via crafted URL to folder with `.prologue.html`
IDs: CVE-2026-32109, GHSA-rcp6-88mm-9vgf
Record: https://patchnext.com/advisories/cve-2026-32109 (revision 2, source checked 26 Oct 2026, 13:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: copyparty 1.20.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI copyparty: affected < 1.20.12; fixed in 1.20.12

## Suggested inspection (read-only)
- `python -m pip show copyparty`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on copyparty.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rcp6-88mm-9vgf (OSV record GHSA-rcp6-88mm-9vgf lists affected ranges: PyPI copyparty >=0 <1.20.12 (fixed))
- Verified: https://github.com/advisories/GHSA-rcp6-88mm-9vgf (GitHub-reviewed advisory GHSA-rcp6-88mm-9vgf lists affected ranges: PyPI copyparty >=0 <1.20.12)

Commands are suggestions: review each one before running it.

Loading voting…